Host not recognized in dashboard

Hello! I’m a total newbie to Rancher, I’m setting up my first VPS on DigitalOcean and decided to give Rancher a try after I came across some tutorials. My problem is that I’m attempting to install everything on one server (or ‘droplet’) because this is just a collection of hobby projects at this point, which looks like it should work, but I started by following a tutorial that was using the built-in DO api for creating hosts (the tutorial is geared more toward a multi-server deployment, which makes sense but just doesn’t fit my use case.) It was very easy to get up and running that way but I ended up accidentally creating a separate host machine/droplet, which I then deleted. The host had been accessible from my Rancher dashboard, and although I still have the Rancher server installed on my Linux box and can access the control panel, it’s giving me the ‘You must create a Linux host before adding services’ message. I’ve tried creating a new Custom host several times, but it never shows up in my dashboard. It looks like Rancher is up and running in my Linux box just fine, but I’m wondering if somehow I hosed up my Rancher instance by launching the first host through DO and then deleting it - I’m hoping I don’t have to delete it and start over, is there another way?


I finally decided to dump the server and reinstall, and was able to add a new server instance and host on the same droplet after that. However, I had also set up the ufw firewall per a Digital Ocean tutorial and had http blocked, I turned it on before launching the new server so that may have also been what fixed it.

Unfortunately, my new host still hasn’t passed all the health checks after 45 minutes and the dashboard is painfully slow. I’m assuming this is in part because it appears that all the ram on my instance is getting used (I have the 1gb ram size), according to the quick start docs it sounds like this should be capable of running (if not advisable) the server and a couple of hosts.

UPDATE: I went to check on the status one more time and the server has crashed. I can’t access the ui dashboard in the browser at my ip address, and I’ve tried running the restart command several times and each time I get an error:
sudo docker run -d --restart=unless-stopped -p 8080:8080 rancher/server
docker: Error response from daemon: driver failed programming external connectivity on endpoint goofy_lovelace (138801a78913653f58971c7cba03935880740ece4b144583de51f46a85c01988): Bind for failed: port is already allocated.

It seems like each time I issue this command it tries to launch a new server instance; I’m unable to find an alternate command in the docs. I tried the docker restart command as well:
docker restart <container_ID>
which doesn’t throw an error but also doesn’t do anything useful.

I think I’m going to give up on this experiment, this seemed like a nice and flexible way to set up an environment that could scale to meet new demands but I am new to docker and this is just way to hard to puzzle through on my own. The quick start guide looked fairly straightforward but I can’t find anything in the docs or on the forums to help with my situation and the forum moderators don’t appear to be very active. There are some good walk-through tutorials on DO for setting up multi-node deployments through their pre-configured hosts and I found it very easy, but I can’t justify the expense of multiple server instances for a personal website. I would not recommend Rancher to a newcomer, I’ll look to something more straightforward like apache or nginx.