Host stuck in Removing State

Rancher version 1.1.0
OS: RHEL 7.2
Docker version: 1.10.3

I note there are several other posts on this same topic, but none really contain a resolution. This issue suggests an approach that one person took (Stuck Process · Issue #3506 · rancher/rancher · GitHub). I could try it, but I’m a bit reluctant to unless there’s no other choice.

So it started with a machine entering ‘Reconnecting’ state (for reasons yet to be understood)

We tried to sort that, but couldn’t in a timely way so decided to remove the host from it’s environment but unfortunately now its stuck in ‘removing’ state, apparently indefinitely ?

I have tried deleting it using the API page and whilst the HTTP response is 200, the host doesn’t disappear from the Rancher UI.

If I try and delete the Network Agent container from with Rancher UI, it shows conflict. No change it I stop the agent manually on the host.

Something else I noticed. When viewing the log of the Network Agent in the Rancher UI it shows as Disconnected ??

Any ideas much appreciate.

Kind Regards