How come 3 private nodes on AWS have the same IP?

Each of these nodes shows the same IP address. Is this normal?

This is not normal. What IP address is it picking up? Was this launched through the UI?

This FAQ is related to picking up potentially the docker bridge IP, but is also relevant if it’s picking up the wrong IP.

Hey @bkuhl, are those hosts on a VPC tier? I’ve seen this with hosts that sit behind a NAT gateway…

Thanks for the responses.

@denise - I’m not sure what you mean by “What IP address is it picking up?” - what ip address are you asking for that isn’t displayed in the UI?

These nodes were provisioned through the UI with me setting the Use only private IP address option. Running the below command leaves the node in a “Reconnecting…” state and never appears to establish a connection. Did I run this correctly?

docker run -d -e CATTLE_AGENT_IP=<NODE_PRIVATE_IP> --privileged -v /var/run/docker.sock:/var/run/docker.sock rancher/agent:v1.0.1 http://<MASTER_PUBLIC_IP>/v1/scripts/<UUID_FOR_NODE_AS_SHOWN_IN_API>

In addition to trying the UUID for the host, I also tried using the 4 character id of the host and the endpoint shows a 404 for both of those. If the docs could be updated to reflect exactly what xxxx is that would be very helpful.

@aemneina - They are on a VPC, yes. When you’ve seen it, how have you solved/worked around it?

If you associate an EIP address with each instance they’ll have unique public IP addresses. Give that a try and let us know how it goes.

Our intention is to keep these nodes private, we don’t want them to have public ip addresses.

Is running your Rancher server on the private network an option? You’d be able to surface that via NAT if you need to publicly access the Rancher UI.

Moving our Rancher master(s) to the private subnet solved this. Thanks for the feedback.