How do I use the new Kubernetes support?

Tried spinning up a new Rancher 0.63 installation in a Vagrant box, but I couldn’t figure out how to create/modify environments to use k8s.

First I tried editing the Default environment, but I couldn’t click the Cluster Management tab. I don’t know if this is an accessibility issue (I’m a blind screen reader/keyboard user) but nothing I did brought this tab up. The text “Coming soon” is nearby, though whether it is visually hidden and in the DOM but still visible to my screen reader I don’t know. If the release notes didn’t indicate k8s was supported, I’d not be thinking much about this control I can’t click.

Anyhow, then I spun up k8s from the catalog in the Default environment, thinking I could create new environments based on it. Nothing seemed to change on the new environment screen, despite k8s’ services being up.

How do I do this? Are there any written docs that describe the steps? Also, do I still need a Cattle-based environment to spin up a k8s stack for other environments to use, or can I do away with Cattle entirely should I choose?


Hi Nolan,

You need to create a new Enivronment and then choose Kubernetes as the orchestration for that environment. Once you’ve created the new environment, you can add hosts and Rancher will automatically deploy Kubernetes.

You don’t need a cattle-based environment. You can delete the default environment once you create the Kubernetes environment. Don’t use the Kubernetes that is located in the catalog, that is not related to Rancher support for Kubernetes. I think that will be removed soon.

Right, tried that but didn’t see an option to select k8s. Should it be on the New Environment screen? Is there any condition that would cause it to not appear? Can I also edit the default environment and switch to k8s, because I didn’t see an option there either.


There’s 3 links under “Cluster Management”, which aren’t tabbable right now. The 3rd one is for Swarm and has “Coming Soon” under it. We have accessibility improvements coming but they’re after the current release.

I don’t know what options you have for finding it but the one you want is:

<a alt="Kubernetes" class="nav-box-item driver orchestration-driver  kubernetes" data-ember-action="2005"></a>

so something like this will work if you can use the browser dev tools:


Ah, the infamous missing href strikes again. :slight_smile: Thanks for the pointer, that is entirely invisible to my screen reader.

We hear you, but it didn’t make it into this release. I don’t know if it will be perfect but the next major release will be better.