How to remove source from chronyc sources -v list

How to remove source from chronyc sources -v list

One of the entries is wrong and I want to remove it. I can’t seems to this.
I’ve tried
chronyc delete wrongEntry

I get the following reply
Could not get address for hostname

wrongEntry = local server FQDN minus the .au (eg server.domain.au should be the correct hostname but it’s showing server.domain instead)

It’s not listed in the /etc/chrony.conf file.

I’ve also tried to add the server.domain.au with
chronyc add server server.domain.au
200 OK

but when I run a chronyc sources, it’s not in the list.

@STCCNL Hi, it’s either configured in /etc/chrony.conf or down in /etc/chrony.d/

@malcolmlewis1 I’ve check both file locations. It’s not in either location.

Would it be different if I say that we have Microfocus Storage Manager running on this server?

@STCCNL Hi, it may, is the host in /etc/hosts? If not you should be able to add as;

xxx.xxx.xxx.xxx server.domain.au server.domain server

So it resolves on the local host, then try deleting again. I always add a conf file in /etc/chrony.d/ pointing at the server or pool to use…

I now can ping server.domain
When I run chronyc delete server.domain, I get a 200 OK reply.
BUT when I run chronyc sources, the server.domain is still in the list.

@STCCNL Maybe a fgrep -r "server.domain" /etc/ may identify where it exists, if just in /etc/hosts then remove and restart chronyd and check again.

Try using the IP address instead of the hostname. Double-check your config files for any typos. Restart chrony after making changes.