How to stop DHCPCD from running during boot?


I recently installed a SLES 11 SP3 server to work as an OES server. I configured all the network interfaces to static ip addresses, but for some reason, dhcpd is being run on boot, which is causing a bogus IP address get configured on the server, which is causing me trouble.

Does anyone knows which files holds this controls? I tried to compare all files with a similar server without this error, but I haven’t found any clue until now.

This is an extract from the problematic server boot.msg:

Well, I found that the file responsible for this configuration is the initrd (/boot/initd-).
Now I need to find a way to force the correction to it.

Solved it… seems that the script /lib/mkinitrd/scripts/ decides whether the default interface’s bootproto is dhcp/static by the presence of the dhcpcd service. But, instead of searching for “dhcpcd”, it searches for “dhcp”, which makes the presence of “dhcpd” service a false positive.

I’ll try to file this as a bug to “mkinitrd” package.

Hi jqueiroz,

great find - thank you for reporting it here (and for bringing it to the developers’ attention)!

Best regards,