HP Server - can't create Linux partitions on logical drives

Having an oddball problem. Have an HP dl380 G6 server using P410i Raid controller (standard issue for this system) and Qty. 6 600GB SAS Hot Plug drives (Seagate). OK, so I launch HP SmartStart and configure the drives for RAID 1+0 (and I tried this also by configuring for RAID 5) and create 3 logical drives. Now, when I boot with SLES 11 sp2 install media and start to setup the Linux partitions I want, a message pops up that says I cannot partition these logical drives but have to create a single mount point for each logical drive. This, to me, is not normal. I should be able to use one of these logical drives and then partition it for /boot, /var, and / partitions as I normally do. I have done this before with other HP servers. In this case, I really need the multiple logical drives because I want one of these logical drives to remain unpartitioned by Linux so that I can setup an NSS partition under OES. Is there something I am missing here? Thanks in advance for any insight.

Hi donahueit,

a message pops up that says I cannot partition these logical drives but have to create a single mount point for each logical drive

that problem is a first for me… do you have any other log output?

If no better advice is available, I’d suggest to go to a console prompt when that message pops up, check how Linux sees your drives at that moment and try to partition them manually (via fdisk) - maybe you’ll receive a more detailed error message hinting at the root cause.


It is now installing as expected, with the ability to partition an HP logical drive. I had setup 3 logical drives, with the first two on a RAID 1+0 array and the 3rd logical drive being just a single drive, Raid 0. It was this single Raid 0 drive that for some odd reason was throwing a monkey wrench into my installation. I eliminated this 3rd logical drive (I didn’t really need it anyway - it was going to be a scratch drive since it was not mirrored). Although that does not really explain why I had this same problem when configuring ALL the drives as a RAID 5 array. I am also now using the cciss.cciss_allow_hpsa=1 installation switch to force use of the HPSA driver, otherwise it would have auto-selected CCISS. Thanks.


Hi Don,

great you got it working and even reported back the cause… those installers won’t cover each and every possible situation and sometimes it only takes a (from the admin’s point of view) minor deviation to irritate the installer… unfortunate, but it simply happens.


HI Don,

I have a new HP Proliant DL DL360p Gen8 and I am having trouble installing SLES 11 sp3 on this server using the ISO image @;


Can not seem to boot off the HDD when trying the initial boot after installation!

When I run system crash & repair seems to indicate a problem with the Kernel! This is a new machine and according to HP the hardwaare is fine but this does not solve my issue

Did you have to do some special configuration of the RAID controller to install SLES 11 ?

Would you have a guide of how you installed it on your HP system?

How can I check that my drivers are up to date especially the RAID controller and such?