Hyper-V module not installed kernel 3.0.101-0.47.52-default


This is my first post on this forum so please, if I don’t follow the guidelines as wanted… Let me know! side-note: My Linux experience is rather outdated since the last couple of years I worked mainly on M$ OS’s.

The issue. I need hyper-v modules:

A client I am working for had this server (SLES 11 SP3 kernel 3.0.101-0.47.52-default) setup in a VMware environment. They now are migrating to Hyper-V on W2k12 R2.

For as far my knowledge reaches I cannot find the LIS hyper-v modules.

Can anyone point me in the direction where:

  • I should find these module in the OS (searched /etc/init.d/ but nothing there)
  • If these are not installed, where I could find these modules?

Also checked in Yast but nothing comes out.

Already adjusted the kernel since I was in the assumption that they would be installed and just needed to load but that does not seems to be the case.

I am following these steps for getting SLES running on Hyper-V;

Kind regards and thanks in advance for helping me out.

Hi HB,

looking at some SLES11SP3 server here, I do see the Hyper-V tools RPM, which is probably what you’re looking for:

[CODE] [FONT=monospace][COLOR=#ff5454]~ # [/COLOR][COLOR=#000000]zypper se hyper-v [/COLOR]
Refreshing service ‘SMT-http_cool_server_over_here’.
Loading repository data…
Reading installed packages…

S | Name | Summary | Type
| hyper-v | Microsoft Hyper-V tools | package
| hyper-v | Microsoft Hyper-V tools | srcpackage
| slessp3-hyper-v | Recommended update for hyper-v | patch
[COLOR=#ff5454]~ # [/COLOR][/FONT][/CODE]


Indeed, that was what I was looking for. Thanks for the tip!

I’m running the kernel rebuild now…

I guess I should see the modules via lsmod in this package after rebooting the server? (hv_vmbus, hv_netsvc, etc.)

kind regards

Hi HB,

I’m running the kernel rebuild now…

usually, you do not recompile on a SLES production server…

Further digging into the subject, I had a look at the contents of the Hyper-V RPM:

[CODE] [FONT=monospace][COLOR=#ff5454]#[/COLOR][COLOR=#000000] rpm -ql -p SLES11-SP3-Updates/sle-11-x86_64/rpm/x86_64/hyper-v-5-0.11.1.x86_64.rpm [/COLOR]



So there’s nothing in terms of kernel modules in that package, but rather daemons. Have you tried looking at the doc file and/or starting the daemons? Probably, the required modules are already part of the distributed kernel.

If manually starting the daemons helps, you can configure their autostart via “chkconfig [FONT=monospace]hv_kvp_daemon on; chkconfig [/FONT][FONT=monospace]hv_vss_daemon on”[/FONT]



First off… Apologies for the confusion and thanks for your help!
To be honest, I do not know I need these Hyper-V tools to get this server to boot after migrating to Hyper-V anyway. I just wanted to make sure I had everything installed on the SUSE guest, guess these tools are for interaction between the host and guest (kinda like vmware-tools).

After some digging I did find the modules I was looking for on the system, at least, I can lookup the information regarding these modules via modinfo hv_vmbus, the only one that is not on the system is hv_blkvsc.

I did do the rebuild because I added these modules to the kernel(bold). Guess they are not initially submitted in the kernel because there was no need since the server is setup on VMWare.
[I]INITRD_MODULES="mptspi ata_piix ata_generic vmxnet3 vmw_pvscsi vmxnet hv_vmbus hv_netvsc hv_storvsc hv_blkvsc”

resource: https://technet.microsoft.com/en-us/library/dn873998.aspx
SUSE Linux Enterprise Server 11 (SP2 and SP3) require additional steps to enable Linux Integration Services when migrating from VMware to Hyper-V.
Perform these steps on the SUSE Linux Enterprise Server 11 SP2 or SUSE Linux Enterprise Server 11 SP3 virtual machine before conversion:
Edit /etc/sysconfig/kernel to include the Hyper-V LIS modules. Add the hv_ modules to the INITRD_MODULES line. It should look similar to this:

INITRD_MODULES="mptspi ata_piix ata_generic vmxnet3 vmw_pvscsi vmxnet hv_vmbus hv_netvsc hv_storvsc hv_blkvsc”

Re-create the initrd with the following command. The kernel specified in the command must match the current kernel that the virtual machine boots with.

mkinitrd -k /boot/vmlinux-3.0.13-0.27-pae.gz -i /boot/initrd-3.0.13-0.27-pae[/I]

I will let you know how things run after the export… I will do the real migration in two steps, if the client agrees I will first, adjust the kernel with the modules. If that is sufficient the Hyper-V tools are just for interaction from the host to the guest.


Hi HB,

I’m running the kernel rebuild now…


Re-create the initrd

seems I mis-understood you - you’re rebuilding the initial ram disk (which is indeed a required step), not re-compiling the kernel (from source). Sorry for the confusion.