Install SLES 11 from either usb or net install


I want to use this dvd iso, and burn it to a thumb drive, and do an install on my server (without a DVD drive) with it:


However, when I’ve attempted to use the openSUSE examples, it’s failed each time.

I format the 4GB thumb drive as Fat 16 and make sure the boot flag is set.

#fdisk -l
Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 7974911 3986432 e W95 FAT16 (LBA)

However, after I cp -R -L the files from the mounted dvd .iso, and use mkbootdisk, it still fails to install.

I’ve checked my BIOS settings and it is set to boot from the thumb first.

Does anyone know of a clearcut guide for installing SLES 11 SP2 via a usb thumb drive?

Also, I’ve never done a net-install, and I was considering using that option.

Any help would be appreciated.


What host OS are you using, SLE? If so have you tried imagewriter?

You could always build up your image on SUSE Studio which will build a
proper USB image as well as many other formats:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 1 day 10:24, 3 users, load average: 0.06, 0.07, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

Hi Rob,

while it does depend on the way your BIOS supports the USB thumbdrive… for both openSUSE and SLES we’ve been doing simple "dd"s to copy the ISO image to a USB drive, stick it into the computer and boot the system. No need for special programs, at least when you already run some Linux.



Using SuseStudio, I created exactly the image I wanted, used dd if=/appliance_name.raw of=/dev/sdb and it worked great!

Thanks so much for your help guys!