java-1_7_0-ibm

I can not find java-1_7_0-ibm package in SLED 11 SP3 repos:

[CODE]$ zypper se java-1

S | Имя | Заключение | Тип
–±----------------------------±--------------------------------------------------------------±----------------------
| java-1_4_2-ibm | IBM(R) Runtime Environment for Linux, Java™ 2 Technology-> | пакет
| java-1_4_2-ibm-devel | IBM(R) Developer Kit for Linux, Java™ 2 Technology Edition | пакет
| java-1_5_0-gcj-compat | JPackage Runtime Scripts for GCJ | пакет
| java-1_5_0-gcj-compat-devel | JPackage development scripts for GCJ | пакет
i | java-1_6_0-ibm | Java™ 6 Runtime Environment | пакет
| java-1_6_0-ibm | Java™ 6 Runtime Environment | пакет с исходным кодом
| java-1_6_0-ibm-devel | Java™ 6 SDK, Standard Edition | пакет
| java-1_6_0-ibm-fonts | Java™ 2 Runtime Environment | пакет
| java-1_7_0-ibm | Java™ 7 Runtime Environment | пакет с исходным кодом
| java-1_7_0-ibm-devel | Java™ 7 SDK, Standard Edition | пакет
| java-1_7_0-openjdk | Java runtime environment based on OpenJDK 7 | пакет
| java-1_7_0-openjdk-demo | Java runtime environment based on OpenJDK 7 | пакет
| java-1_7_0-openjdk-devel | Java runtime environment based on OpenJDK 7 | пакет
| libdb_java-4_5 | Java Bindings for the Berkeley DB | пакет
| matthewlib-java-javadoc | A few useful Java libraries | пакет
i | sdksp3-java-1_6_0-ibm | Security update for IBM Java | исправление
| sdksp3-java-1_7_0-ibm | Security update for IBM Java | исправление [/CODE]

Also needed java-1_7_0-ibm-jdbc java-1_7_0-ibm-plugin java-1_7_0-ibm-alsa. Why they are absent into SLED repositories? OpenJDK do not works with my applications…

The ninth entry in your pasted output is the one you are seeking in your
subject…
[color=blue]

| java-1_7_0-ibm | Java™ 7 Runtime Environment[/color]

Start there… maybe it happens to include other important pieces too, but
I cannot tell for sure. Tried looking on the SDK media?

Good luck.

В Срд, 24/07/2013 в 21:45 +0000, ab пишет:[color=blue]

The ninth entry in your pasted output is the one you are seeking in your
subject…
[color=green]

| java-1_7_0-ibm | Java™ 7 Runtime Environment[/color]

Start there… maybe it happens to include other important pieces too, but
I cannot tell for sure. Tried looking on the SDK media?

Good luck.[/color]
No it is not. The ninth entry is a source package, not a binary runtime.
SDK have a devel package for IBM Java 7 but it is requires runtime
environment.
I have a look to patch
https://www.suse.com/support/update/announcement/2012/suse-ou-20121051-1.html

  • there mentioned product “SUSE Linux Enterprise Java 11 SP2” but not
    “SUSE Linux Enterprise Desktop 11 SP2”. What is this?

    Regards, Alexey Svistunov

My bad… I missed the last column because of, well, a bunch of URL
encoding or something… anyway, we’re looking into this to see what is
missing with the SLE packages in SP3.

Good luck.

26.07.2013 0:55, ab wrote:[color=blue]

anyway, we’re looking into this to see what is
missing with the SLE packages in SP3.
[/color]
java-1_7_0-ibm is SDK packages, they are not present into SLED.

Into SLE11-SDK-SP1-Pool:
java-1_6_0-ibm-1.6.0_sr7.0-1.6.21.i586.rpm
java-1_6_0-ibm-devel-1.6.0_sr7.0-1.6.21.i586.rpm
java-1_6_0-ibm-fonts-1.6.0_sr7.0-1.6.21.i586.rpm

Into SLE11-SDK-SP1-Pool:
java-1_6_0-ibm-1.6.0_sr13.1-0.9.1.i586.rpm
java-1_6_0-ibm-devel-1.6.0_sr13.1-0.9.1.i586.rpm
java-1_6_0-ibm-fonts-1.6.0_sr13.1-0.9.1.i586.rpm
java-1_7_0-ibm-devel-1.7.0_sr4.1-0.5.1.i586.rpm

java-1_7_0-ibm-1.7.0 is absent, no plugin, no jdbc, no alsa…

And what is SUSE Linux Enterprise Java 11 product yet? May be I need it
for complete IBM Java kit on Desktop product?

On 26/07/2013 09:59, svalx wrote:
[color=blue]

And what is SUSE Linux Enterprise Java 11 product yet? May be I need it
for complete IBM Java kit on Desktop product?[/color]

I’m not sure as it doesn’t appear to be a downloadable product. Asking SUSE.

HTH.

Simon
SUSE Knowledge Partner


Do you work with SUSE technologies at a university, college or school?
If so, your campus could benefit from joining the Technology Transfer
Partner (TTP) program. See novell.com/ttp for more details.

Hi
We have heard back from our SUSE Contacts, it appears that these
packages are only supplied for SLES and not SLED with the release of
SP2.

I do note, since the src rpm is there, why not install that and rebuild
locally?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 13:11, 3 users, load average: 0.32, 0.28, 0.27
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

В Чт, 15/08/2013 в 03:20 +0000, malcolmlewis пишет:[color=blue]

Hi
We have heard back from our SUSE Contacts, it appears that these
packages are only supplied for SLES and not SLED with the release of
SP2.

I do note, since the src rpm is there, why not install that and rebuild
locally?
[/color]
Yes, I can rebuild ti locally, thank you for advice. But I’m don’t
understand why, for example, IBM java plugin package exists only for
Server product. It is a traditional desktop application, and not uses on
the server side…


Regards, Alexey Svistunov

I do note, since the src rpm is there, why not install that and rebuild[color=blue][color=green]
locally?
[/color]
Yes, I can rebuild ti locally, thank you for advice.
[/color]
In fact I can not rebuild it locally.

# zypper source-install java-1_7_0-ibm

downloads java-1_7_0-ibm-1.7.0_sr5.0-0.5.1.nosrc.rpm package, that
really not contain java sources.

Hi
Sorry for the delay… The spec file should indicate the sources
required and a download URL?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 7:06, 3 users, load average: 0.03, 0.07, 0.13
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

19.08.2013 16:09, malcolmlewis пишет:[color=blue]

Hi
Sorry for the delay… The spec file should indicate the sources
required and a download URL?
[/color]
Oh yeah, I build these packages, thank you malcolmlewis! I downloaded
bin sources from the link on IBM site that is given in the spec file.