keyboard acts strange under hyper-v

We are running SLES 11.3 as a virtual machine under Windows 2012 Hyper-V. On some of the VM’s the keyboard acts strange when I open a console session. If I open a gnome terminal and type in anything whatever I type in is underlined. If I run the VI editor and enter ‘x’ to delete a character, I have to hit the enter key for it to work. If I open a Konsole terminal anything I type is has a black background. If I open an xterm console anything I type in appears in a little popup window until I hit the enter key. We have another SLES server at the same release level and it does not have those problems, but I can’t see what is different between them. I tried copying the keyboard, windowmanager, and displaymanager from the ‘good’ server to the ‘bad’ one, but that had no effect.


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team