Load Balancer performance really slow


I’m having issues where when using the load balancer requests are taking 50 secs before serving begins. Taking a look at the proxy config I can see the following lines which seems to make sense.

    timeout client 50000                                                    
    timeout server 50000      

I’ve created the hosts using the digital ocean integration and when not using a load balancer via a service alias everything performs as expected.

Any ideas what I may have done wrong?

Using 0.52 of the server.


Further information :

29/12/2015 17:28:22e[32minfoe[39me[37m: Microsoft.AspNet.Mvc.Controllers.ControllerActionInvoker[1]e[39m
29/12/2015 17:28:22e[97m Executing action method WhoAmI.Controllers.HomeController.Index with arguments () - ModelState is Valid’e[39m
29/12/2015 17:28:22e[32minfoe[39me[37m: Microsoft.AspNet.Mvc.ViewFeatures.ViewResultExecutor[1]e[39m
29/12/2015 17:28:22e[97m Executing ViewResult, running view at path /Views/Home/Index.cshtml.e[39m
29/12/2015 17:28:22e[32minfoe[39me[37m: Microsoft.AspNet.Mvc.Infrastructure.MvcRouteHandler[2]e[39m
29/12/2015 17:28:22e[97m Executed action WhoAmI.Controllers.HomeController.Index in 0.0012mse[39m
29/12/2015 17:28:22e[32minfoe[39me[37m: Microsoft.AspNet.Hosting.Internal.HostingEngine[2]e[39m
29/12/2015 17:28:22e[97m Request finished in 0.0014ms 200 text/html; charset=utf-8e[39m

It looks as if the load balancer doesn’t realise the request has finished, the timeout occurs at 50 seconds as per the HAProxy config.

Not sure where the issue lies at the moment.

Ok, so the issue is with Kestrel on ASP.NET 5 RC1 stack. The issue is due to be addressed for RC2 however for now adding the following as defaults in the load balancer yield a huge performance increase.

option forceclose
option http-server-close
option http-pretend-keepalive

I just want to clarify that this is something on your end and not Rancher’s end, correct?

Hi, yes that’s correct.