Ls: cannot access 'docker-machine-driver-*': No such file or directory

Hi, first of all this is the second time im posting this issue im having with rancher, the original Post was in slack: Slack
This is also my first posting in this forum so if this seems out of place please feel free to move this topic.

I have an issue provisioning RKE2 Clusters on Nutanix as an infrastructure provider, whenever i create a cluster the pods trying tu pull the node driver from rancher and failing.

Logs of the Pod failing to download the driver:

Downloading driver from
Doing /etc/rancher/ssl
ls: cannot access 'docker-machine-driver-*': No such file or directory
downloaded file  failed sha256 checksum
download of driver from failed
Stream closed EOF for fleet-default/test-pool1-59010ecd-5zmwj-machine-provision-k59jh (machine)

After some digging i found that that the secret fleet-default/cluster-pool1-***-machine-driver-secret mounted by the pod possibly contains the wrong proxy configuration and the pod will try to download the driver via the proxy which is not possible on our network. (Proxy is only used for internet acces).
Note that i have also tried pulling the driver with a curl container and on the k8s nodes themselves and that worked.
Secret looks something like this:


note that and others are missing int no_proxy compared to the rancher helm deployment values.

Rancher has been deployed via Helmchart with the following values:

additionalTrustedCAs: true                                                                                                                 
bootstrapPassword: initPW                                                                                                                  
  extraAnnotations:                                                                                                                    letsencrypt-prod                                                                                               
privateCA: true                                                                                                                            
replicas: 5

Is there any other way to set the no_proxy variable for the provisioning of nodes other then when deploying the helm chart? I also cannot edit the secret directly because it gets deleted/ recreated with every deployment attempt made by rancher/ fleet.
Any help on this topic is highly appreciated.

Thank you very much in advance,

I figured out the suolution. In Helm vars no Proxy Veriables have to be set as noProxy instead of the rather common no_proxy. Just documenting it here if anybody stumbles upon the same issue.