Missing HAE Repositories.

Anyone have experience with suse cloud 5? I’m trying to create my cluster of “control nodes” using pecemaker, but when i click in apply in crowbar web interface, gives me a error of “HAE repositories”, i already entered the repositories in yast crowbar of admin node, and in the repositories of my two control nodes , but keeps given me this error.


I have had some experience with repositories myself with suse cloud 5.
According to the deployment guide (and my own experience) you can’t change the repositories in yast crowbar after you have installed your cloud nodes, all changes are overwritten by Chef. You would have to reinstall your cloud, if you wanted to change your repository settings.
How do you provide repositories for SUSE Cloud? In my first attempts I used a remote SMT-Server and now I use SUSE Manager. It took a while to find out which repositories are optional or mandatory, but now I have a working cloud, except it doesn’t work with SLES12 on compute node.
If you had any logs maybe I could tell you more. I have to add that I don’t have a HA setup, so the HAE repos are optional in my environment, but I also get a hint in the logs that these repos are missing.


Thanks Eugen!
when you installed using suse manager, in yast crowbar repositories what you put in your repositories? you set the address of suse manager?

Exactly, you can find a description here: https://www.suse.com/documentation/suse-cloud-5/singlehtml/book_cloud_deploy/book_cloud_deploy.html#sec.depl.adm_conf.repos.scc.remote_susemgr
If you want to use SLES12 on Compute Nodes consider this thread: https://forums.suse.com/showthread.php?6401-SUSE-Manager-Channels-URLs-for-Cloud-5&utm_expid=46697118-16.N1XypdTaS7yHl5c5HmYkdw.0&utm_referrer=https%3A%2F%2Fforums.suse.com%2Fforumdisplay.php%3F65-SUSE-OpenStack-Cloud
I added the missing channels for SLE-12-Cloud-Compute5-Pool and SLE-12-Cloud-Compute5-Updates as they are still “to be announced” in the deployment guide. Maybe another look in this blog will help you: http://heiterbiswolkig.blogs.nde.ag/2015/08/12/suse-cloud-5-repositories/
I tried to summarize which repos you need if you want to use SUSE Manager.

Hope this helps!

I added HAE repositories in that blog, I’m not sure if they work, you’ll have to try out. But at least I don’t get any warnings or errors, so it seems to be correct.

Thanks a lot for the blog post! And if you feel the documentation is unclear on any of these points, please feel free to submit bugs.

By the way it should definitely not be necessary to do a complete reinstall in order to add repositories. They are dynamically detected on a periodic basis by the provisioner barclamp.

We already did that once or twice, we’ll keep doing it :wink:

That would be really great, I tried that in one of my early attempts and it was not possible to change the repositories. I’m not sure, though, it could be due to incorrect network settings or something else I could have misconfigured.
I must have missed this part in the documentation:

Sorry for any misleading information.