Mount qcow2 Image

SLES12 SP1 with xen and 2 VM’s. 1 VM will not boot. This VM is windows 2012 R2. I would like to mount the qcow2 image and see if i can get the VM to boot. When i run:

modprobe nbd max_part=63
qemu-nbd -c /dev/nbd0 /path/to/qcow2/image.qcow2
mount /dev/nbd0p1 /mnt/image

I get: mount: unknown filesystem type ‘ntfs’

Is there any way to mount a windows VM on to the SLES12 filesystem? If you can’t, does anyone know of a way to mount the qcow2 file on any other system in a read/write fashion?

Mount with the ntfs-3g driver, which may be part of the SLED (Desktop)
repositories since it’s not normal for a server to need to mount a windows
filesystem like a desktop might.

With regard to what you can do from here, you could potentially use ‘dd’
to pull all of the data from the mounted disk, write it to a raw file, and
see if another system can open it. Better yet, just add the ntfs-3g
packages to SLES, build a SLED system (download media just like you
probably did SLES), and use that instead.

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…

I added the SLED ISO as an Add-On to our SLES 12 server and installed ntfs-3g. However, after i run:

mount /dev/nbd0p1 /mnt/edge
I get:

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount ‘/dev/nbd0p1’: Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the ‘ro’ mount option.

Mounting with the’ro’ option will not allow me to manipulate the data in the image. Anyway to force it to mount?