MySQL 5.5.28-1 install on SLES 11 sp2 - any tips/tricks?

Have just setup a SLES 11 sp2 server under VMware. We want to run current version of MySQL (5.5.28-1) so I uninstalled (via Yast) the existing version on the SLES 11 server and then installed the 3 rpm files (server, client, shared) for MySQL, downloaded from the MySQL site. Did get a couple errors installing the server module:
ls: can’t access /var/lib/mysql/*.err “no such file or directory”
insserv: service network is missed in the runlevels 4 to use MySQL

Then I ran mysql_install_db.
Then I ran mysql_secure_installation. Here where it asks for the password I just hit enter since there presumably should not be a password yet but I get an error back “Can’t connect to local MySQL server through socket /var/lib/mysql/mysql.sock”

Not sure what is going on here - whether or not the errors upon the install of the MySQL server rpm files are preventing these other utilities to run.

Any tips/pointers on how to get this up and running would be greatly appreciated. Thanks!

If you going outside the ‘box’ why not look at the Open Build Service
versions for SLE?

This will also give some clues as to the compile options if you look at
the rpm spec files.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 2 days 0:41, 4 users, load average: 0.18, 0.14, 0.08
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU