MySQL Community Server 5.1.54 on openSUSE 11.1 (SLES 11 sp1)

MySQL Community Server 5.1.54 on openSUSE 11.1 (SLES 11 sp1) Error 2003

Yesterday MySQL stopped working on my server. I can’t connect remotely,
at the command line or locally.

I’ve tried using localhost which returns the error can’t create

I’ve tried using which returns the error 2003 (Can’t connect
to MySQL server on (111)

I’ve tried installing MySQL 5.0.67 and removing MySQL Community Server.
I’ve also tried updating to 5.1.30 and no matter what I do I can’t
establish a connection.

When I check restart the server (sudo /etc/init.d/mysql restart) The
server shuts down and restarts but gives the error that
/var/lib/mysql/mysql.sock could not be created in 30 seconds.

Any help would be appreciated. Where do I go from here? This is a
server at my college and I’m just taking over as admin for the box. The
/etc/my.cnf is correct and has the socket = /var/lib/mysql/mysql.sock


var/lib/mysql$ ls -lhd /var/lib/mysql
drwxr-xr-x 23 mysql mysql 4.0K 2011-09-23 10:55 /var/lib/mysql


/var/lib/mysql$ sudo /etc/init.d/mysql start
Will update MySQL now, if you encounter any problems, please read following file:
Log files inconsistency, please merge following files manually:
Running protected MySQL…
error: /var/tmp/mysql-protected.JiUX4s/mysql.sock file didn’t appeared…
Try checking “/var/log/mysql/mysqld-upgrade-run.log”…

This started after I updated the broken repo…openSUSE_11.1/ to ‘Index of

At which point I tried changing from MySQL 5.0.67 to MySQL Community
Server 5.1.54 to see if that would fix the 2003 error. I did check the
log files and the shared library files are erring out with No such file
or directory.


110922 19:21:01 [ERROR] Can’t open shared library ‘/usr/lib/mysql/plugin/’ (errno: 0 cannot open shared object file: No such file or directory)
110922 19:21:01 [Warning] Couldn’t load plugin named ‘EXAMPLE’ with soname ‘’.
110922 19:21:01 [ERROR] /usr/sbin/mysqld: unknown option ‘–skip-federated’
110922 19:21:01 [ERROR] Aborting

Thanks again for any assistance the forum members can lend.


jsw1130’s Profile:
View this thread:

Googling for your error, I found that you posted at another suse forum
I looks like you did not do, what the members there suggested.
Have you tried to delete the socket file?
Have you checked that there is space left on the /var/lib/ filesystem?
Have you tried to remove all the mysql packages, install again from a
reliable source und restore your databases?


MoserHans’s Profile:
View this thread: