New to Suse - Chrome/Chromium

Hello - I am new to Suse from Debian/Ubuntu.

Can someone point me in the right direction when I am attempting to install Chrome (downloaded from google)?

I am evaluating SLED 12 in a VM before purchasing and installing on a new laptop.

This is what I am getting:

sudo rpm -Uvh google-chrome-stable_current_x86_64.rpm root's password: warning: google-chrome-stable_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY error: Failed dependencies: lsb >= 4.0 is needed by google-chrome-stable-39.0.2171.71-1.x86_64

Looking up LSB this is what I found:

[CODE]matt@linux-rld8:~/Downloads> zypper if lsb-release
Loading repository data…
Reading installed packages…

Information for package lsb-release:

Repository: SLED12-Pool
Name: lsb-release
Version: 2.0-23.13
Arch: noarch
Vendor: SUSE LLC
Installed: Yes
Status: up-to-date
Installed Size: 16.2 KiB
Summary: Linux Standard Base Release Tools[/CODE]

I ran the install just find in openSUSE 13 and when I looked at lsb-release it looked like a similar version number (at least in 2.x-xx.xx). I double clicked the rpm and it started downloading dependencies. I don’t get that behaviour in SLED 12.

I am also wondering about backports in SLED 12. I can find information on openSUSE, but much less for SLED. Where do I need to look?

I do occasionally need a new feature in postgres, haproxy, etc., thus this is a bit of a concern for me. I have tried a number of things but with no luck.

Thanks for pointing me in the right direction!


Hi Matt,

I haven’t tried this myself on SLE12… it should be the quickest/easiest ticket to getting Chromium installed and also keep it updated in a convenient way:

imo is the most convenient way to get software installed on (open)SUSE systems. Do watch out for unsupported “home brew” repositories in there (as anyone can build and publish packages there using OBS - the Open(SUSE) Build Service SUSE offers). Often you’ll find decent packages there, but there is always a risk as they are generally untested builds.


Your better off to use zypper from the command line rather than rpm,
this will pull in expediencies. In saying that you can ignore the lsb
error and force via no-deps. If it still spits and error on running,
just create a softlink so it finds lsb_release.

Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Willem - This worked well and will suffice for my purposes. Thanks for letting me know openSuse resources are a good option with caution.

Thanks! Matt

I tried zypper and it told me that the needed dependencies could not be found. I went with the openSUSE package of Chromium for now. I learned a lot from your tip. Thanks!