NFS volumes on bare metal

I’m in the process of trying to migrate to Rancher from bare metal K8S on CoreOS. Although most things are much more straight forward I’ve hit an issue with NFS mounts that I use for my persistent volumes from our on site NFS servers.

Warning FailedMount 6s kubelet, uk-dev-rancheros-02 MountVolume.SetUp failed for volume “rancher-pv1” : mount failed: exit status 32
Mounting command: mount
Mounting arguments: -t nfs /opt/rke/var/lib/kubelet/pods/82fadced-c324-11e8-bb98-005056a62873/volumes/
Output: mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use ‘-o nolock’ to keep locks local, or start statd.

Anybody come across this before on Rancher 2.0 or should I be opening an issue for it. I’m running the latest RancherOS and Rancher 2.0.8. I’ve added *(no_root_squash) to my export for now in case the mount was coming from an odd address but it made no difference.

Adding nolock seems to let some things work but the recycler pods still fail with the same error when trying to release the PVC and that doesn’t seem like a proper fix anyway.

I think this question is actually how do I use NFS v3 with Rancher 2.0?

When I enable nfsv4 on my server it works fine but i’d rather use v3 as then i get hardware acceleration from the NAS server.

I am also facing the same issue any help will be much appreciated…