No space left in device : Cant's install rancher on rancherOS


i just tried to setup some RancherOS VMs but i’m failing at the the second step:

  1. Create a VM in VMWare-Workstation:

  2. tried to pull rancher/rancher:

[root@rancher ~]# docker pull rancher/server
latest: Pulling from rancher/server

0105f98ced6d: Pull complete
66395c31eb82: Pull complete
0105f98ced6d: Download complete
bc429a1fdad4: Download complete
44fe4c810607: Download complete
2de29b8b195a: Download complete
aafb06da86f9: Download complete
cfcec90bc7a0: Download complete
cfcec90bc7a0: Pulling image (latest) from rancher/server, endpoint: https://regi cfcec90bc7a0: Error pulling image (latest) from rancher/server, endpoint: https: //, link /var/lib/docker/overlay/0852676832f8ab30623ce8b b4fc261c136cb7f91139accd03b1737789101d0b3/root/usr/share/doc/openssl/HOWTO/keys. txt /var/lib/docker/overlay/22f4487bfc2dada31de81af7bcc08a5afcaca545e703021f8983 1d88d5161539/tmproot430764769/usr/share/doc/openssl/HOWTO/keys.txt: no space lef cfcec90bc7a0: Error pulling image (latest) from rancher/server, link /var/lib/do cker/overlay/0852676832f8ab30623ce8bb4fc261c136cb7f91139accd03b1737789101d0b3/ro ot/usr/share/doc/openssl/HOWTO/keys.txt /var/lib/docker/overlay/22f4487bfc2dada3 1de81af7bcc08a5afcaca545e703021f89831d88d5161539/tmproot430764769/usr/share/doc/ openssl/HOWTO/keys.txt: no space left on device

i tried different “guest configs” like “ubuntu 64bit” or “any linux 64bit” with 10,20 or 50GB split in 2GB files or one large vmdk.

It is all failing with the same error “no space left on device”.

Also i tried to do all this with VirtualBox instead of VMWare Player. The same error…

What VM-Software you’re using to create a guest for RancherOS and what for settings do have?


Have You tested with live system booted from iso?
You need storage to save the images and containers which will be configured during install to hdd.
Take a look at Persistent State Partition here:

If you only booted from iso, you’ll be running from memory. To take advantage of your storage, you need to either install to hdd (

Thank you guys. It’s working… Sry for not reading the installtion guide :confused: