RancherOS with VMware


I’m trying to setup rancher os v0.42.0 in ESXi 6.0 and Workstation 12 but i always have the same error, boot is OK but when i try to ping a machine in my network it outputs me a single response and then it hangs the server! already tryed to change network configuration to all types and the problem persists. I don’t have any firewall in servers network.

Anyone had problems with VMware too ?


Have not tried ESXi, but VMware Fusion works flawless for me.

Your problem with pinging another host from the rancher os ssh shell is reproducable with the rancher user, but not if you sudo your command.

Even with the rancher user it does not hang the server, though it freezes the shell process. You can still access rancher os with a new ssh connection.

Tested on ESXi 6.0 and rancher os 0.42.0.

When the user rancher pings another host, the process is listed in ps as executed by root. To unblock the stuck ping command the process can be killed from a second ssh connection using the root user.

Seems like a permission issue.


@metin Thanks for your support, i think it was it :slightly_smiling:

Anyway, now i’m stuck with this error:

Error pulling image (v0.4.2) from docker.io/rancher/os, ApplyLayer exit status 1 stdout: stderr: write /lib/x86_64-linux-gnu/liblzma.so.5.0.0: no space left on device

This last error is clearly a disk full problem. You need a larger disk for your install.

We have successfully installed RancherOS under VMWare (ESXi6), though it did not work until the latest version of the install ISO. I installed with a 40GB drive the first time, but a 16G should easily be enough to hold the images etc.

However, if you are running VMWare ESX, I’d suggest you instead use CoreOS. This is available as an OVA file, and has VMWare tools support built in. It works well with Rancher currently, and is easy to manage via a mounted ISO holding the cloud-config.yml file.


I also think it was a disk problem but i had a 40GB disk, so when i deployed my VM it was only 384mb memory, i increased to 2GB and it installed with no problems.

Anyway, RancherOS become very hard to deploy around here and i decided to go for CoreOS + Rancher for orquestration.


In my experience, you at least need 2G RAM for system performing nicely. RancherOS is way more elegant than CoreOS IMHO.

While RancherOS will probably work better with Rancher, the main reasons for us using CoreOS both centered around our using VMWare. CoreOS comes as a VMWare OVA, so installation was simple; also the CoreOS OVA has VMWare Tools installed and configured so that the VMware monitoring gets all the necessary data. Were we using physical servers I would most likely go with RancherOS; if RancherOS came in an OVA with VMWare tools then we’d be using it.