NVMe CLI issues on opensuse15.5/15.4


I use nvme cli for testing of NVMe drives and some of my testing requires the use of nvme cli to send commands to the drives. I have made sure that I am using the latest revision of nvme cli (2.4) so my issue is not related to that.

when I run the command “nvme show-regs /dev/nvme0n1” I get an invalid argument error but if I run the same command in our older centos systems it returns the correct/expected output. The older centOS system is running an older rev of nvme cli also.

Is this a known bug? What would anyone advise here?
Happy to provide more info if needed.



@khokha Hi what does the following show on a system that works zcat /proc/config.gz | grep CONFIG_IO_STRICT_DEVMEM I suspect that it’s the older kernel and changes (more lockdown, secure boot etc) with newer ones… On openSUSE it’s CONFIG_IO_STRICT_DEVMEM=y

@malcolmlewis1 no such file exists on a working centos system

Hi @malcolmlewis1 should CONFIG_IO_STRICT_DEVMEM be disabled?

@khokha No… you need to find out where a Centos kernel config is stored and check. But I suspect the issue is later kernel changes from a security perspective.

What is your end game with this nvme command, as in what details of the device do you require?

the command is part of a larger test script, I am checking to see what controller registers are supported by the drive.

found the config kernel on the centos

@khokha So I suspect that is why it works… But you may wish to create a bug report to confirm, or look for alternatives. Times are changing, secure boot, more kernel lock down features enabled etc…


Thanks for your help and input!