Offline Upgrade SLES 12 SP5 to 15 SP5 Fails

  • The upgrade process does not detected any partition to update.

  • If we select show all partitions it shows the SLES 12 SP5 partition but after the selection and press continue it gives /mnt/boot/efi mount failure.

  • How can we handle this? Thanks in advanced.

Hi All,
After some google searching it seems to me that the problem is related with the use of the HPE driver cciss that must be changed to hpsa in /etc/fstab before the upgrade.

I have scheduled for the next friday (11/06/2021) to make a new upgrade attempt and after the intervention i will post the result.


  • HPE Proliant DL580 G9 + SLES 12 SP5 for SAP


Hi All,
Intervention in progress …

Hi all,
Changing the file /etc/fstab from cciss to hpsa worked in conjunction to the change made to the GRUB menu, adding hpsa.hpsa_allow_any=1 parameter at ISO boot.

But now we face the following issue.

Hi All,

HPE Proliant DL580 G9

Offline Upgrade SLES 12 SP5 to 15 SP2 done successfully!

  1. In the file /etc/fstab we changed all mount points from cciss to hpsa;
  2. Downloaded and make the boot with SLE-15-SP2-Online-x86_64-GM-Media1.iso file;
  3. When GRUB menu appears select T, select Upgrade, CTRL+e to edit, and add the hpsa.hpsa_allow_any=1 parameter;
  4. CTRL+x to save and start the Upgrade;
  5. When asked fill the network settings and proceed with the Upgrade (make sure you have internet access);

Note.: After the upgrade we had to reconfigure the name servers.

New discussion in the following link:
Offline Upgrade SLES 12 SP5 to 15 SP2 Fails (Solved)