patchs Category not showing in custom repositories

i replicated suse 11.2 updates repository and run the repodata on that folder.
when i run zypper list-updates i see many updates but when i run zypper list-patchs nothing is listed.
i tried the same command directly aginst$RCE/SLES11-SP2-Updates/sle-11-x86_64/ , and only then i see the secuiory categiries list im looking for.

am i missing somthing when creating my own repodata.
is repodata does not create the security categoris i need.
how do i check for patchs with my custom repositires.


example for a the required list.

zypper lp --repo sles11-sp2-updates

Loading repository data…
Reading installed packages…
The following software management updates will be installed first:

Repository | Name | Version | Category | Status
sles11-sp2-updates | slessp2-softwaremgmt-201306 | 8047 | recommended | needed

The following updates are also available:

Repository | Name | Version | Category | Status
sles11-sp2-updates | slessp2-Mesa | 7805 | security | needed
sles11-sp2-updates | slessp2-MozillaFirefox | 8187 | security | needed
sles11-sp2-updates | slessp2-NetworkManager | 7600 | recommended | needed
sles11-sp2-updates | slessp2-SLES-SP3-Migration | 8065 | recommended | needed
sles11-sp2-updates | slessp2-audit | 7578 | recommended | needed

Have you tried to force a refresh of the repositories?

zypper ref --force

PS, it’s SLES 11 SP2 not 11.2 (as this reference clashes with the
openSUSE release numbering) :wink:

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…