Please help a noob get setup


I’m new to Rancher and I am having a bit of trouble getting setup.

I’m running in a home-lab environment so nothing mission-critical. I have a MacMini that I use to host Docker containers (macOS version of Docker) and I have started using Portainer which has been great to get some basic services setup with ease.

I really want to give Kubernetes a go with Rancher though. I watched some videos on YouTube for assistance getting set up but as I am running v2.5.1 it seems ever so slightly different from what I’ve seen.

I used a stack in Portainer to get the Rancher container setup with the following docker-compose:

version: "2"
    image: rancher/rancher:latest
    container_name: rancher
    network_mode: bridge
    privileged: true
      - 7080:80
      - 7443:443
      - /Users/serveradmin/rancher:/var/lib/rancher
    restart: unless-stopped

It deployed the container without a problem, and I can log into Rancher and set a new password, etc.

What has thrown me after this is that there is already an active cluster called “local” which I didn’t create. This hasn’t been present on any of the tutorials I watched online. For now, and because I don’t know any better I have just left that alone.

I have tried to create a new cluster and then deploy the Rancher agent in a new container. Under the customize node run command options I ticked etcd, Control Plane and Worker. I ran the following command in the terminal of my MacMini:

sudo docker run -d --privileged --restart=unless-stopped --net=host -v /etc/kubernetes:/etc/kubernetes -v /var/run:/var/run rancher/rancher-agent:v2.5.1 --server --token cjhgrrr6w4mgz2bvwtkn85pnqv7xmx97n9p48jq8tc94mkwsdlmkjl --ca-checksum 97776f09bfd79b53b59ea0ef03dba6e7c99f9fbafd68b448d3e5b1bff10be7a6 --etcd --controlplane --worker

The cluster will not provision. I get a red error saying:

"This cluster is currently Provisioning ; areas that interact directly with it will not be available until the API is ready.

Cluster must have at least one etcd plane host: failed to connect to the following etcd host(s) []"

If I go back in to the customize node run command area within that cluster the etcd and Control Plane options are now unticked.

I would really appreciate any help.

Thanks in advance.