Properly enable TopologyAwareHints


  --kube-apiserver-arg=feature-gates=TopologyAwareHints=true \
  --kube-scheduler-arg=feature-gates=TopologyAwareHints=true \
  --kube-controller-manager-arg=feature-gates=TopologyAwareHints=true \
  --kube-proxy-arg=feature-gates=TopologyAwareHints=true \

on all server-nodes and

  --kube-proxy-arg=feature-gates=TopologyAwareHints=true \

on all agent-nodes with, auto annotation on the service, the hints forZones are successfully created in the corresponding EndpointSlice.

However I’d like to know where exactly the feature-gate TopologyAwareHints must to be enabled to get this working, as right now I set it on apiserver , scheduler, controller-manager and kube-proxy but this might be “too many places” – but I don’t want to trial&error here.

Thank you!