Racher server shows a blank screen when adding a host

I have installed Rancher as a container on RHEL host that has no internet access.

I want to add the server that runs the rancher as a host. When I click on the add host screen, I get a blank screen. Not sure why that is

I see some errors in the log such as unable to update repo cache as it is trying to access github ( no internet access(

I tried to add a custom host through the agent command provided
sudo docker run -d --privileged -v /var/run/docker.sock:/var/run/docker.sock rancher/agent:v1.1.3 http://dpvmdevapisoa2.tracfone.com:9001/v1/scripts/

What are these securityt credentials that I need to give here. Are these the API Keys generated? When I use this command , a container is created. However, cannot see this host in Rancher server. Tried this from same server and a different one.

Also, cannot click on Admin settings. Nothing happens.

Not sure what is the process? can some one elaborate how this works. My understanding is that when I add host in the Rancher Server UI, I need to see a host registration URL. Am I right. But, right now, I dont see anything

BTW, I am using rancher/server:v1.6.0 and rancher/agent:v1.1.3

Really urgent, Any help would be appreciated