Rancher 2.2 and Trident csi not working

Hi, i am trying to get Netapp Trident working with Kubernetes 1.14.
Env : centos7 as vm, Rancher 2.2 and Kubernetes cluster 1.14, provided by Rancher.
Install Trident works fine, all pods up and running. I can define backend, storage classes and pvc. But while trying to mount pvc in a container, the log show ”Node has no NodeID”.
Kubectl get csinodes or get csinodeinfo show : no resources.
Added explicitely the feature-gates for kubelet and kube-api-server, no change.
When looking at the logs, I see trident-main listenung on csi.sock but the corresponding registrator container can’t connect to the socket (still connecting to…) Any ideas? Thx in advance /Frank

which version of Trident? We are running 19.07, starting at Rancher 2.2.8 and now up to 2.3.2 on 1.14. But it was a fresh Trident install. Did you upgrade from older Trident?

Sorry, just saw that I didn’t mentioned this. It is 19.10 and a “brand new” install. Tried it several times and ran an uninstall incl. delete of namespace first.

Solved : it was SELinux prohibiting the pods to connect
to the socket. In permissive mode, it works. Have to adjust the selinux profile.