Recreating cluster fails


I am trying to create and manage my bare metal Kubernetes clusters using Rancher and RKE and I have some issues while I delete and recreate a new cluster using the same nodes. I tried to follow the official documentation to cleanup the nodes (remove containers, volumes, directories, reboot, …) but it does not solve my issue. The issue is while I run the command to register my node, the rancher-agent container start and fail to register the node with the following message:

time="2020-06-11T15:42:29Z" level=error msg="Failed to connect to proxy. Response status: 200 - 200 OK. Response body: Operation cannot be fulfilled on \"m-2a05ebe1536e\": the object has been modified; please apply your changes to the latest version and try again" error="websocket: bad handshake"

About one minute later, another container is created and try to run the script and this container will try to start the kubelet without any sucess:

+ docker start kubelet
Error response from daemon: {"message":"No such container: kubelet"}
Error: failed to start containers: kubelet

Another rancher-agent is created, and this container seems to be doing nothing.
I’m really new to Rancher and RKE so maybe I am missing something.
Anyone can help me?
Thank you

Bump. Having this same issue as well.