Rancher Desktop stuck "waiting for services"?

Hi all,

I’m using Rancher Desktop 1.5.1 and it seems that every now and then it will just hang at the “Waiting for services” step. Does anyone know what could be causing this, or how to resolve it?
In the cri-dockerd.log file I have this line:
time=“2022-09-02T07:55:43Z” level=info msg=“Using CNI configuration file /etc/cni/net.d/10-flannel.conflist”

That’s following by time=“2022-09-02T07:55:44Z” level=error msg=“ContainerStats resp: {0xc000c9f540 linux}” with a different hex number a few times before it looks back to that CNI configuration line. Eventually it just seems to give up after about 10 minutes of trying and failing.

The only difference between when it worked yesterday and worked today is that today I am working from home - although I worked from home also on Monday and didn’t have any issues then.

I had same issue.
I ran below commands and worked
docker rm -f <container_name>
and then try docker-compose up -d again
it should work.