Rancher has never successfully installed

Hey Everyone,

I have been trying not to ask questions to much and now I am so thoroughly frustrated that I am forced to ask for help. Ever since I learned about rancher I have tried to install on microk8s, I have tried so many tutorials that I am blue in the face from it. I can not believe it is this hard to install. I was wondering if someone out there had a good tutorial (for Rancher on Microk8s) that actually works either article or video. This is the last tutorial I used → 5 Minute Kubernetes

Failed Install:

Thank you for your time.

kubectl describe pod rancher-ff955865-6lvdn -n cattle-system is the command I’d try first. What you’ll see there is that you have some init containers that are failing. If that doesn’t give you the info you need, you may need to check the logs.

I got this on my first Rancher install because the docs said if I wanted to register my own CA I should do the install and then upload the CA cert in a secret, where actually that’s backwards and you need to create the CA secret first (I think it still worked when I added it after, just got unnecessary errors like you see above on that).