Rancher Install problem holding settings

Hi All,

I have installed RancherOS a couple of times now on a VPS, but there seems to be some problems with it holding the settings when it is reboot.

I have followed the procedure very closely and was able to install it on one of two VPS machines without any problems, but when I install it on the 2nd one, after I do things like “sudo passwd rancher” and change the password, as well as using the bash method “sudo bash; passwd rancher” and change the password then things are fine, but after I complete the install by setting up the minimal “cloud-config.yml” then reboot, then the settings are gone.

In one attempt, I was able to go through the while process, but then I changed the “/etc/hostname” with no problems and rebooted, but the RancherOS did not hold the hostname change.

Still another attempt, I was able to install, change the rancher password, and even the hostname, which all came up good until I tried to login via the SSH key or ssh direct, in which it would not let me login.

The final attempt, I was able to get all of the above to work, briefly but then installed the Rancher Server:

sudo docker run -d --restart=unless-stopped -p 8080:8080 rancher/server


and then it would not hold those settings.

Not sure what is happening here but I am wondering if others have experience such problems and perhaps may know how to fix it?

I installed from the “RancherOS 1.02 LTS” iso that was mounted to the VPS cdrom drive and after the install, but before the reboot that it asks for, I unmount the iso and boot from the freshly installed hard drive “/dev/sda/”

Any ideas?

Thanks in advance,

Hi All,

I have found that if I do a complete shutdown of the VPS, not from the ssh connection with the RancerOS install script and then reboot that it seems to hold the settings and configurations.

from this point,

I logged into the system via the SSH keys and installed the Rancher Server onto the RancherOS;

On the Linux machine with Docker installed, the command to start a single instance of Rancher is simple.

$ sudo docker run -d --restart=unless-stopped -p 8080:8080 rancher/server



but after everything installs, I tried to use my browser (Chrome) to do to port 8080 on the newly installed Rancher Server but am getting “This site can’t be reached, . . . . refused to connect.”

even though the container is running:

[rancher@rancher ~]$ docker ps
5078f6a5cf41 rancher/server:latest “/usr/bin/entry /u…” About a minute ago Up About a minute 3306/tcp,>8080/tcp sad_borg

I have tried the “LATEST” and “STABLE” installs of the Rancher Server with the same result and am not sure what is happening.

Any ideas?