Rancher Managed Network Timeout 15 minutes?


We’ve been running a PHP:5.6 Apache container behind a rancher HAProxy LB and recently we realized that even though HAProxy has a timeout of over 2 hours, requests passed to this container appear to timeout at 15 minutes exactly.

When hitting the container using wget from the RancherOS machine and running


wget will come back and say that it timed out. (The script just sleeps based on the seconds that are passed in via URL).

When running the same command but logging into the machine via docker exec -i -t xxxxxxxxxxxxx bash

wget http://localhost/src/timeout/index.php?seconds=930

the command runs fine.

When I run the command locally to a docker container without rancher’s managed network services, the script correctly returns after 15 minutes or more (900+ seconds). This to me proves it isn’t

  • HAProxy
  • Docker
  • Apache

but instead RancherOS.

Is there anyway to configure what the TCP timeout is for the managed rancher network?

I’ve already tried tweaking sysctl to no avail of the rancher OS image:

[rancher@staging ~]$ sysctl -a | grep keepalive
net.ipv4.tcp_keepalive_intvl = 75
net.ipv4.tcp_keepalive_probes = 24
net.ipv4.tcp_keepalive_time = 7200

We are using cattle for orchestration.

Thanks for any insight.