Need help locate the assets file(s) in running container

We have just recently installed Rancher 2.4.
In one of the previous versions were able to update the ui-light.css in the running Rancher container by directly editing the ui-light.css files in the /usr/share/rancher/ui/assets/ directory / folder but in the v2.4 this isn’t happening.

After deploying the container I’m able to access the deployed container but the assets are getting loaded from (supposedly transient) directory called latest-2.4 (like <>/ui/latest-2.4/assets/ui-light.css )

So can anyone suggest on how to update the UI, the ui-light.css, the images, etc?

If you are running a real regular release (v2.x.y, stable or latest), then the ui is bundled into the image and served locally by the Rancher container by default

Only non-release builds (like -rcs and -head builds) default to loading the UI from our CDN (where would be You can change settings to cause it to be loaded from your URL instead of ours, or point at the local copy in the image. But generally shouldn’t be using non-releases to begin, with as we don’t support upgrades from/to/through them.

Hi Vincent,
As mentioned earlier, I’m running the real regular release v2.4. and I have tried:
• changing the assets
• removing the ui directory in the /usr/share/rancher but these steps still don’t affect the deployed Rancher web app.

So I’m wondering if the deployed running Rancher container is loading the files from within the container or is it creating a directory called 'latest-2.4' on the fly?

If you view the page source (the real “View Page Source” that shows the actual server response, not the current generated DOM tree), is src/href of the script/link tags to a complete url? You said <> earlier; is that your domain or ours (

As I said in real releases the default is hosted locally by the rancher container. So either a) it’s not a release build, or b) someone has changed the ui-index setting on your installation from its default value of local to a remote URL.

# 2.4.11
mercury:~ vincent$ docker run -d --privileged -p 443:443 rancher/rancher:v2.4.11
Unable to find image 'rancher/rancher:v2.4.11' locally
v2.4.11: Pulling from rancher/rancher
Digest: sha256:9d4c160fc69733cd23e9e7f2d09885aa729745f561359bb1029d2aa3ceed9ef0
Status: Downloaded newer image for rancher/rancher:v2.4.11
mercury:~ vincent$ curl -H 'User-Agent: Mozilla' -k https://localhost:443 2>/dev/null | grep '<script '
    <script src="/assets/vendor-b6fe2bee7d805b67cfdacf9d6f4cd5f8.js"></script>

# 2.5.3
mercury:~ vincent$ docker run -d --privileged -p 443:443 rancher/rancher:v2.5.3
Unable to find image 'rancher/rancher:v2.5.3' locally
v2.5.3: Pulling from rancher/rancher
Digest: sha256:b2a4d88133d17e079f394883bb9ab7e91bb6f68664547039feed7b2bd2f9dfae
Status: Downloaded newer image for rancher/rancher:v2.5.3
mercury:~ vincent$ curl -H 'User-Agent: Mozilla' -k https://localhost:443 2>/dev/null | grep '<script '
    <script src="/assets/vendor-6f130daf0a74563125625410603d6a7c.js"></script>

# Master
mercury:~ vincent$ docker pull rancher/rancher:master-head && docker run -d --privileged -p 443:443 rancher/rancher:master-head
master-head: Pulling from rancher/rancher
Digest: sha256:b70f3cc58c088171033547f96587b2294864c6b3be264e5f490c35c937605966
Status: Image is up to date for rancher/rancher:master-head
mercury:~ vincent$ curl -H 'User-Agent: Mozilla' -k https://localhost:443 2>/dev/null | grep '<script '
    <script src="//"></script>

Hi @vincent
Thank you so much for your support. I am now able to use v2.4.4 to get the assets load from within the container. Really appreciate your prompt replies.

I have another quick question though.
I tried deploying two versions:

  1. v2.4.4
  2. v2.5.3

in the second version (2.5.3) I wasn’t able to work with the Amazon EKS (Hosted Provider). Rancher showed error like ‘cattle—something’ not found. Which is why I had to switch to v2.4.4.

Could you tell what could be the reason behind the error ?

Not without some real context to look at, the entire backend of Rancher is internally called cattle.

Hi @vincent
This is regarding the error:
Cluster health check failed: deployments.apps "cattle-cluster-agent" not found

Screenshot attached below:

I’ve just started a docker container by using the following command:
sudo docker run --privileged -d --restart=unless-stopped -p 80:80 -p 443:443 rancher/rancher:stable
It started Rancher v2.5.5 in which I’m trying to work on Amazon EKS (hosted service) by entering the Access token and credential but I’m facing this error every time.

Could you please advice what could be done?

Thank you so much for your support.