Rancheros install

Still facing some issues while installing OS on bare metal. I would like to confirm couple of things…
Do I need to run sudo mkfs.ext4 -L RANCHER_STATE /dev/sda before I run racnheros-install?
this is the error I am getting:

  • install_grub
  • grub-install --boot-directory=/mnt/new_img/boot /dev/sda
    Installing for i386-pc platform.
    grub-install: warning: Attempting to install GRUB to a disk with multiple partition labels. This is not supported yet…
    grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged…
    grub-install: error: will not proceed with blocklists.
  • umount /mnt/new_img

No, you should not need to run sudo mkfs.ext4 -L RANCHER_STATE /dev/sda before running rancheros-install. Did you run it before the command and getting these warnings/errors?

I tried both options and both gave me the same error…

Are you using the right iso? I built my bare metal servers using machine-rancheros.iso (the wrong one) and got that error. Using rancheros.iso (the right one) made the problem go away. :slight_smile:

like @MichaelDays said,

  1. use rancheros.iso
  2. make sure the disk you’re installing to is not partitioned: fdisk -l
    This will list all existing partitions. If you see partitions on the disk where you intend to install RancherOS (e.g. /dev/sda):
/dev/sda1               3       98113    41942016  83 Linux

then before running rancheros-install, you need to wipe all partitions from that disk. Run fdisk /dev/sda, and on the prompt enter m to get help, then use d command to delete existing partitions and finally w to write down the modified partition table to disk.
3) Run rancheros-install -f -d /dev/sda -c cloud-config.yml
Easy :wink:

Just to be abundantly clear:

  1. Make sure you don’t want whatever was on that partition, because it’s about to be gone forever :slight_smile:

I was missing -f option; however, now I am stuck during the boot on 9pnet: Could not find request transport: virtio

Also ended up at “could not find request transport: virtio”. I read on another GH repo (looked like a guide to using it in China) that there’s a problem when there’s more than one network interface. Not sure if that is the case or not.

@pl33g0r What is contained in your Cloud Config? Typically, users are running into this error due to their network configuration.

We are currently working on v0.4.0, which is a major refactoring of RancherOS to give our users more control on customization.

this is network park of my cloud-config file
hostname: rancher01
- ssh-rsa
dhcp: true

Can you share what is in the rest of your cloud config? Also, can you share it in the proper yaml format? I want to check the whitespacing of the file as yaml is quite particular on it. :smile:

Please note that we currently don’t support adding users through cloud config, so that could be an issue.

Also, all the networking needs to be under rancher: and not rancher01: even though you changed the hostname.