RancherOS -Vagrant: host-only network does not work


I am following this document: http://docs.rancher.com/os/running-rancheros/workstation/vagrant/ to run rancher OS with Vagrant (version 1.7.4) and Virtualbox (v5.0.6 r103037 on Mac OS X).

Once the VM is up and running, I can login with cmd “vagrant ssh”. But the VM’s network setup looks strange and I can not ping the VM from my host:

On my Mac laptop, Virtualbox created a host-only interface as vboxnet0:

vboxnet0: with IP
The routing table has a route to 172.19.8/24 network use vboxnet0 device.

On the rancher VM, it has following interfaces and IP addresses:

docker-sys: with IP
docker0: with IP
eth0/eth1: no IP assigned

As you can see, the host and the VM are not even on the same network! If I manually configure VM’s eth1 interface with IP, the host and the VM can ping each other successfully.

What’s going here ? Can someone tells me how do I fix it ?



1 Like

some problem here :(. It appears that only ipv6 addresses get configured but not ipv4. It’s not a Vagrant problem, tried the same Vagrantfile with the precise32 box, which works fine.

Same issue here, im using windows with vagrant + virtual box

RancherOS 0.3.3 worked, it assigned a ipv4 address, but in the latest, this does not seem to be the case.