Registry_mirror argument on cloud-config not working for console pull

I am using rancher v0.7.1 with pxe. It worked very well so far.

We’re using a local registry mirror to make things faster.

Now I’m pulling an ubuntu console as default, but rancher seems not to obey the directives that are set on cloud-config.

  console: ubuntu
    registry_mirror: http://xxxxxxxxx:5000
    registry_mirror: http://xxxxxxxxx:5000

registry_mirror works only if I pull from the command line (docker pull rancher/os-ubuntuconslole:v0.7.1), but not at boot time and neither using “sudo ros console switch ubuntu”.

Am I doing something wrong?

Thanks for the help!

You could use the private registries cloud-config option. Though you’d also have to provide authentication for the alternate mirror.

I’ve added authentication to the local registry (htpasswd - its working ok), and enabled private registry as follows:

      username: yyyyyy
      password: zzzzzz
  console: ubuntu

But it still fetch the console from the internet not from local mirror.
Without registry_mirror option, it is not redirecting docker pull connections.
When I use registry_mirror option, it doesn’t use the credentials supplied.

Hi, Joshwget!

Looks like this problem was solved on some point in the rancher RCs, I don’t know where it was.

But to solve some other issues (to have ceph jewel version on kernel), I tested the rc6, and the ubuntuconsole started to be queued on the registry_mirror that was set.

It was not working in v0.7.1.

Thanks for the help!!