rescan FC bus in SLES11 SP1 ??

We’re migrating a group of SLES9 boxes, HP DL385/585 running as Oracle
servers, to SLES11 SP1. Also adding new HP BL460 G7 blades at the same
time. We’ve hit a major stumbling block when it comes to adding FC LUNs
on the fly from our EMC CX3-80 and new VNX 5500.

Previously, the steps were simple, totally reliable, non-disruptive,
and used hundreds of times:

echo “scsi-qlascan” > /proc/scsi/qla2xxx/0
echo “scsi-qlascan” > /proc/scsi/qla2xxx/1 --luns=0-45 (or some appropriate number)
powermt config

It appears that this variant worked at one time for SLES11:

echo 1 > /sys/class/fc_host/host2/issue_lip
echo 1 > /sys/class/fc_host/host3/issue_lip
echo “- - -” > /sys/class/scsi_host/host2/scan
echo “- - -” > /sys/class/scsi_host/host3/scan
powermt config

And now it doesn’t work for SLES11 SP1. Suse support provided a Qlogic
script that worked on 2 boxes and crashed a 3rd. And will not work on
the blade servers since they have the Emulex CNA. It was suggested that
the “ -i” should be all that is needed since it will
do a LIP to see the new LUNs. Does not work. We’ve tried this using both
mpio or Powerpath for multipathing. No difference. EMC documentation
for Emulex connectivity says that you must either reboot or reload FC
and scsi drivers.

Does anyone have an alternate method to non-disruptively rescan a FC
bus for new LUNs that works under SLES11 SP1 ??

Don M.


tgic-systems’s Profile:
View this thread:


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

  • Visit and search the knowledgebase and/or check all
    the other self support options and support programs available.
  • You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team


In our environment (also SLES11-SP1), the following script rescans all
multipathed disks:


$ for DISK in $(echo “show paths” | multipathd -k | grep active | awk ’ { print $2 } '); do echo 1 >/sys/block/${DISK}/device/rescan; done

Hope this helps.
Kind regards,


amo_vzug’s Profile:
View this thread: