Services don't start whith action=activateservices

I’m trying to activate services using the Rancher API and it seems the exact same URL used in the UI is ignored if I use the API. From API view on a stack (environment), I can activateservices and it works as exepcted - the services all start up. But using the API externally, it seems to be ignored. I even opened up developer tools in my browser, and didn’t see any clue.


Any ideas?

I’m falling back to the having the services start automatically when I create the stack, but I’d rather the the control.

All latest versions of everything…

Hey @ebishop, do you see anything in the rancher server logs? I was able to issue activate[/deactivate]services, using POST, just fine using the API… also running the latest.

Sample of my api command, using cURL:
curl -X POST “http://ENDPOINT/v1/projects/1a5/environments/1e4/?action=activateservices” -u APIKEY:SECRETKEY

I saw nothing in the logs. I worked around it by just activing each service in the stack (environment).

Did it return 2xx? The only thing I can think of is that the action isn’t available in the state the stack is in, but you’d get a 405 back in that case.

Docker 1.11 related…again - that’s my guess.

I’ve had a test running almost since I’ve been using Rancher, that adds a VM, creates and starts a service and then deletes the VM instance in Openstack. The inability to start a service was one problem. Rancher would also never delete VM instances when I deleted them in the UI or via the API. After rolling back to Docker 1.10.3, this test worked this morning for the first time in a few weeks. So I suspect this is another Docker 1.11 related issue.

I had assumed that there were undocumented API changes or something like that, and had given up on using Rancher to create VM in Openstack. So know I have some working code that creates and activates a service, so this one can be clsoed.