Set WSL2 subnet

Hi, We are using Rancher desktop with WSL2. Each time we open the Rancher desktop or after restarting computer , the WSL machine behind Rancher Desktop takes random IP’s. This conflicts sometimes with other subnets in my LAN creating “no route to host” conflict when trying to connect from WSL guest to one of those other subnets.

I need to be able to set more specific /20 block for WSL2 so that the conflict never occurs any longer. The only workaround I found was to reboot the host computer, so that WSL network is randomly re-assigned from a different block that does not conflict with my other subnets.

I was not able to find any way to modify the settings of vEthernet (WSL) adapter or in Rancher Desktop. While this adapter is enumerated by ipconfig, it does not show up in Control Panel / Settings. Is there a way to set the vEthernet (WSL) subnet to a specific block range?