I am really new in Linux, and I got a system with SUSE Linux Enterprise Desktop 11 SP2.
I tried to install Skype using different recommendations. Always I got the message that the installation was finished (no error) but when I click on the skype icon it doesn’t make anything - don’t open, don’t give any error.
Can someone help me with this issue?


You need to open a terminal and run the command to see what errors it’s

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 2 days 18:58, 6 users, load average: 0.01, 0.03, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

Exactly what have you installed?

If you run Skype from command line

$ skype

is there any output?

I haven’t updated Skype from version 4.0. Last time I looked at 4.1 I came to the conclusion that there isn’t a version of 4.1 that works with SLED 11 SP2. I have the 4.0 static build, but even that doesn’t work without a little hassle because Skype messed up the build. Also it’s only available as a 32bit build so you may need to install extra packages to get it working on 64bit machines. I can tell you how exactly how to get it Skype 4.0 running (it is still on their download server, you just have to know the exact url), if you can tell me whether you’re using 32bit or 64bit. If you’re not sure post the output of

$ uname -a

Actually, come to think of it, it’s not harder enough for 64bit for it to be worth worry about whether you’re using 64bit or not.

If you are using 64bit then install the package libtiff3-32bit. You can do that from, amongst other places, ‘Install Remove/Software’ in the Computer menu.

After than open a command prompt and run these commands:

$ curl | tar xvfj - $ cd skype_staticQT- $ ln -s /usr/lib/ $ mv skype skype.real $ cat > skype << EOF #!/bin/bash WHATRUN="\\${0}" if [ -n "\\$(readlink "\\${WHATRUN}")" ];then WHATRUN=\\$(readlink "\\${WHATRUN}"); fi SKYPEDIR="\\$( cd "\\$( dirname "\\$WHATRUN" )" && pwd )"; LD_LIBRARY_PATH="\\${SKYPEDIR}" "\\${SKYPEDIR}/skype.real" & disown EOF $ chmod u+x skype
Don’t type the $ that’s just the standard notation to represent the command prompt.
The first command fetches a compressed file that contains a version of Skype that works with SLED 11 SP2 from Skype’s download server, it’s then piped to the tar command which un-compresses it. All the rest of the commands are required because Skype messed up the build so it doesn’t ‘just work’ on some versions of Linux, including SLED 11 SP2.
You can then run skype with

$ ./skype[/CODE]

If you want to have an icon in the Application Browser then at the same command prompt, run these commands
[CODE]$ mkdir -p ~/bin
$ ln -s "${PWD}/skype" ~/bin/
$ mkdir -p ~/.local/share/applications
$ ln -s "${PWD}/skype.desktop" ~/.local/share/applications/
$ mkdir -p ~/.icons
$ ln -s "${PWD}/icons/SkypeBlue_48x48.png" ~/.icons/skype.png
$ killall application-browser 2>/dev/null

Note that all of this sets up Skype just for your own usercode.


I install Skype from the skype webpage = skype- I have a 32 bit system installed.
When I tipe Skype i get the follow

/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option “menuitemstyle” is not supported and will be ignored.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option “listviewitemstyle” is not supported and will be ignored.
/usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option “progressbarstyle” is not supported and will be ignored.
skype: symbol lookup error: skype: undefined symbol: _ZN9QListData11detach_growEPii

[QUOTE=cioinacrazvan;11279]I install Skype from the skype webpage = skype- I have a 32 bit system installed.
That’s the one which the Skype website is built for openSUSE 12.1. You’re not using openSUSE 12.1 :wink:

Get the Dynamic version of 4.1. That appears to work in SLED 11 SP2. Which surprises me, because I’m sure last time I tried the Dynamic version of 4.1, it didn’t work. Which is why I posted the guide to get working. Curious. Oh well.


I understood the ideea.
For you it is look very simple.
I done what you recomment before for skype and it doesn’t work. Maybe I did something wrong

Who do I install the Dymanic version 4.1?
Is a tar.bz2 file which I downloaded in my computer

Sorry, I mentioned at the begining that I am new on this Linux OS not only in SUSE
Many thanks for understanding

No problem.

You don’t need to install the Dynamic version. tar.bz2 indicates it’s a compressed archive. It’s like a zip file but a different compression method. So all you need to do is uncompress it and then run the executable inside. If you double click the .tar.bz2 file it should open in the file-roller archive managed and you can just drag the folder you see listed to where ever you want. Inside that folder is a file called skype, double click that, it should run.

With the Dyanmic version you don’t get an icon in the Application Browser. If you want that, it can be done using the method in the last part of my guide for If you are bothered about that I can give you some guidance on that, and how to make it run automatically when you log in if you want to do that. Otherwise just open the folder and double click the skype file when you want to run Skype. If you look at the README file that’s included in the Dynamic version you’ll see a section entitled INSTALLATION. I recommending not doing anything it advises in there unless you really understand what you’re doing. I wouldn’t do what it advises because I don’t think it’s a very good idea, but maybe that’s just me.

Many thanks.

I succeed to install Skype.
It was easier then I thought.
It is true that is doesn’t start automatically when I start the system, but is OK.
I put an Icon on desktop and it easy to start ti.

For future reference, I just worked out which packages are required to get the Dynamic version of 4.1 working on 64bit SLED 11 SP2:
I guess if you remove the -32bit from the names, those are the packages you need to get it working on 32bit SLED 11 SP2.

Hi there.

I would also like to pose a question about Skype. I have a laptop with factory installed 64bit SLED 11 SP2. It also has a old Skype Beta Version 2.2.what,ever installed. It works perfectly but is a bit unpractical with the separate chats and everything.

I dowloaded the Dynamic Version, unzipped it, however doubleclicking the Skype file gives no result.

So… should I uninstall the version I have before trying to get the ?

Also could you clarify the command lines after “cat > skype << EOF”… are they on separate lines or…?

Thanks a lot.