SLED 11.3 AMD driver for FirePro W5000, black screen


In a fresh install of SLED 11.3-x64, after activation and all updates, I tried to install AMD Catalyst driver 12.104.2 for FirePro W5000, it went well till the reboot.

Installation procedure was exactly how it was advised here

sh ./ --buildpkg SuSE/SUSE-autodetection
zypper install fglrx64_xpic_SUSE121-8.950-1.x86_64.rpm

but for ‘fglrx-12.104.2’

Now since there is nothing but a black screen after GRUB menu apparently I’ve done something wrong.

Any help is appreciated,

Did you boot to runlevel 3 and then run;

sax2 -r -m 0=fglrx

Else when SLED is activated, it should automatically add the ATI
repository to download/install the pre-build rpms.

I follow the section “Building yourself the rpm” here;
It contains an init script that will rebuild the driver after a kernel

Also, your not using secure boot on the system?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 7:29, 3 users, load average: 0.79, 0.49, 0.38
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

Used the drivers from repos, and sax “sax2 -r -m 0=fglrx” actually worked … removed the watermark and all good now.