SLES 15.4: libreoffice installation fails on broken dependency


I have tried to install libreoffice from the latest SLES 15.4 iso, but I get the following error message:

nothing provides ‘’ needed by the to be installed libreoffice-

It seems that this version of SLES provides liborcus versions 0.14 and 0.16, but not 0.17, at least not in a binary format. I have tried using QU1 as well as latest QU2 of SLES 15.4, with equal result. It appears that 0.17 binary can be retrieved from opensuse, but this brings a number of further dependencies to handle (our target systems do not have access to the internet, so I will have to handle all dependencies manually; it is not just to add another repository in yast).

But I find this strange – is it not the case that a release is supposed to be self-contained, in that all software packages required for all software are included in the iso file?

@susejoaer Hi, Libreoffice and liborcus-0_17-0 are part of the Workstation Extension Module so you would need to have that subscription for that module.

Thank you for your reply! How do I go about getting such a subscription?

@susejoaer Hi you would need to contact your SUSE Sales Representative.

OK, thanks for the information!

@susejoaer You can also get a 60 day evaluation code via if logged in and add via SUSE Customer Center.

Great, thanks, I will look into it.

A follow-up question: I followed the URI to download/sle-we, and got the impression that Product-WE is part of the main SLE 15.4 full version ISO which I already downloaded. Do I need a subscription (or trial activation code) to unlock something in order to retrieve the correct versions of liborcut to satisfy libreoffice dependencies?

@susejoaer yes you need a .subscription for SLES as well