SLES 15 SP2 on Raspberry Pi 4 8GB RAM

Hi, does SLES 15 SP2 support Raspberry Pi 4 8GB RAM? Last time I tried it cannot boot. I can boot and SSH if I tried openSUSE Tumbleweed.

Please read SLES 15 SP2 release notes, chapter “8 Arm 64-Bit-Specific Features & Fixes (AArch64)”:
Fore more general information about SLES and SLED support for Raspberry PI 4 see:

If you select Ubuntu Server 20.04 LTS for your Raspberry Pi, you shall take care of:

  • some unsupported software packages:


=> 4 could receive security updates with ESM Apps
dnsmasq => universe
rng-tools => universe (for hardware random number generator)
u-boot-rpi => universe
linux-firmware-raspi2 => multiverse

  • snapd => Disable snapd for security reasons:

snap remove lxd

snap remove core18

snap remove snapd

apt purge snapd

  • partition layout => Replace ext4 partition by xfs partition:
    Start rescue mode from a sled or sles installation media

mkdir /usr/lib/microcode/efi

mkdir /usr/lib/microcode/root

mkdir /usr/lib/microcode/backup

/dev/sdc => mini sd card for Raspberry Pi

fsck.vfat -rvV /dev/sdc1

fsck.ext4 -f /dev/sdc2

mount -r /dev/sdc1 /usr/lib/microcode/efi

mount -r /dev/sdc2 /usr/lib/microcode/root

mount /dev/sdd1 /usr/lib/microcode/backup

cd /usr/lib/microcode/efi

tar -cf /usr/lib/microcode/backup/myraspi_efi_YYYYMMDD.tar *

cd /usr/lib/microcode/root

tar -c --xattrs --one-file-system -pf /usr/lib/microcode/backup/myraspi_root_YYYYMMDD.tar *

umount /dev/sdc1

umount /dev/sdc2

cfdisk --zero /dev/sdc

=> dos
Gerät Boot Anfang Grösse Kn Typ Bezeichnung Dateisystem Typ
/dev/sdc1 * 2048 256MB c W95 FAT32 (LBA) system-boot FAT32 Primär
/dev/sdc2 Rest 83 Linux writable xfs Primär

mkfs.vfat -n SYSTEM-BOOT -f 2 -F 32 /dev/sdc1

fatlabel /dev/sdc1 system-boot

fsck.vfat -rvV /dev/sdc1

mkfs.xfs -m reflink=1,crc=1 -fL writable /dev/sdc2

mount /dev/sdc2 /usr/lib/microcode/root

umount /dev/sdc2


df -h


xfs_repair /dev/sdc2

mount /dev/sdc1 /usr/lib/microcode/efi

mount /dev/sdc2 /usr/lib/microcode/root

cd /usr/lib/microcode/efi

tar -x -f /usr/lib/microcode/backup/myraspi_efi_YYYYMMDD.tar

cd /usr/lib/microcode/root

tar -x --xattrs --one-file-system -pf /usr/lib/microcode/backup/myraspi_root_YYYYMMDD.tar

vim /usr/lib/microcode/efi/cmdline.txt

=> rootfstype=xfs

vim /usr/lib/microcode/root/etc/fstab

=> add “,attr2,inode64,noquota” for new xfs partitions

Thanks, I’ll take a look