[Solved - kind of] Errors in rancher log (and two host not usable)

I see a lot of these:

[> apply.sh:8] curl -f http://localhost:8111/v1/reload

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (7) Failed to connect to localhost port 8111: Connection refused
[apply.sh:9] echo Failed to reload ipsec config

Also, on the host not usable for now there’s a bunch of these processes suggesting networking issues:

root 25300 0.0 0.0 6568 740 ? D 04:58 0:00 ip xfrm state add src dst spi 42 proto esp mode tunnel aead
root 25713 0.0 0.0 17980 2852 ? S 04:59 0:00 /bin/bash /etc/init.d/rancher-net start

Now, what do I try next? I have two hosts that are currently out of order. I’ve removed them from rancher, removed /var/lib/rancher and added them again to no avail.

[edit 2]
The course was a kernel upgrade to 4.2.0-whatever for other reasons. The XFRM kernel module crashed and disabled ipsec networking. Now why a newer kernel should be worse off is the next question.
[/edit 2]

Apologies, but I don’t completely follow what your current issue is at this point.

Can you provide some more information as well? Rancher version, docker version, OS?

Hi. Currently I have no issues left.
I’m on 0.56.1, docker 1.9.1 and ubuntu 14.04. For other reasons we upgraded the kernel to 4.2.0-something (from the ubuntu tree) and it worked fine - until two days ago. Now this is a different setup from the AWS instances we usually run (it’s OpenStack based). The AWS instances work fine with the 4.2 kernel, the OpenStack based decided to do so no longer.
I haven’t been in touch with the cloud provider for more information on what changed in their setup. It was outside Rancher, so no worries on your part.

Thanks for the update!