Suse all kernels deleted by mistake ๐Ÿ˜“

Dear community members,

I have a rather desperate situation and need your advice.

I have a laptop with Suse 15.4 installed. I have updated the system yesterday to the latest kernel version 5.14.21-150400.24.49.3 and when I tried to boot today the system failed to boot.

I used Grub menu option to boot the previous kernel version 5.14.21-150400.24.46.1 to boot and it worked.

So I thought I would just remove the kernel that didnโ€™t work and used the version that worked. I used the command line :

zypper rm kernel-default-5.14.21-150400.24.49.3.

Ran the command, removed the kernel but when I rebooted again all I have is the grub menu.

I donโ€™t know why but that command it removed both kernels. Now I donโ€™t have anything to boot.

Please see the photos:

I donโ€™t know where to go from there. Is it possible to restore the system? Please, I need some advice.

Thank you,


Perhaps you can follow the steps suggested in this article, which seems similar to your situation : Deleted kernel - Install/Boot/Login - openSUSE Forums

Further references :

Rgds, Eirikur.

Thank you very much! I managed to boot in, copy data in my /home and reinstalled the system.

Lessons learned.


1 Like