SuseManager Ansible does not recognize Inventory

Hello to all,
Have any of you ever had this problem?
Somehow the Suse Manager does not recognize the servers that are definitely managed by it.
Is there a setting in the SuseManager that still needs to be activated?

My reading of Setup Ansible control node | SUSE Manager 4.3 Documentation suggests that you need to create and add your hosts to /etc/ansible/hosts - I don’t think it uses SUSE Manager’s own “inventory”

Exactly. SUSE Manager does not do this either.
It only manages the devices. It also knows the devices that it manages. As shown in the picture, there is the item: “Registered Systems”. Unfortunately, my devices are missing here.

The file /etc/ansible/hosts only contains host names and SUSE should compare this machine with its own managed (Registered Systems). Alternatively, the devices should be listed under “Unknown Hostnames”. Which it does not do either

I have found something in the official Suse document about the new features in Suse Mananger 4.3. In this document there are also no registered machines listed.

I have already found an answer to the problem. I simply added the necessary SSH key to the inventory of the Ansibles with the parameter “ansible_ssh_private_key_file”

For example:
server.local: {ansible_ssh_private_key_file: /root/.ssh/sshkey}