System in English but error messages displayed in German

I want the system to be completely in English, and mostly it is. But when logged in with a user other than root the error messages on the konsole are displayed in German. Also in YaST2 the categories are displayed in German. How can I fix this?

Hi monika,

how’s the users’ LANG set up?

[QUOTE]juser@host:~> echo $LANG
de_DE.UTF-8[/QUOTE]

The default comes from /etc/sysconfig/language, see “RC_LANG” there:

[QUOTE]#

Local users will get RC_LANG as their default language, i.e. the

environment variable $LANG . $LANG is the default of all $LC_*-variables,

as long as $LC_ALL is not set, which overrides all $LC_-variables.

Root uses this variable only if ROOT_USES_LANG is set to “yes”.

RC_LANG=“de_DE.UTF-8”[/QUOTE]
To change the default language via YaST, go to “System” - “Language”

Regards,
Jens

echo $LANG gives de_DE.UTF-8

RC_LANG in /etc/sysconfig/language is “en_US.UTF-8”.

YaST: “System” - “Sprache” (as YaST is half in German) shows “English (US)” as primary language. German is not ticked as secondary language, nor is anything else.

I also just noticed I cannot type | (with Alt Gr + <) or \ (with Alt Gr + ß) etc., even though I have otherwise a German keyboard layout (z, y, ß work alright). German, US English and French layouts are activated and I can switch between them by clicking on the flag, just Alt Gr doesn’t work. :frowning:

Hi monika,

obviously it is not as easy as it seemed first… for the sake of clarity, which version of SLES do you run (see i. e. “cat /etc/SuSE-release”)

/etc/profile.d/lang.sh would be the script that is in charge of setting the general language, and uses either /etc/sysconfig/language or the user’s individual settings (from ~/.i18n) for this.

It might be interesting to see how things are set up when you log in to a normal (non-graphical) shell, i.e. via ssh or a text console log-in - then it’d be “the system” doing the setup, in contrast to the graphical environment.

From your description (“by clicking on a flag”) you’re running a graphical environment, probably KDE - which has it’s own way of setting user-specific settings for NLS. Maybe that is responsible for the effects you see - and maybe there are inconsistent environment variables set by it (LANG vs. LC_*), causing parts of the YaST code to look up messages in the wrong catalog?

The keyboard problems may be caused by having selected the wrong keyboad type (I’m not talking about “layout”, but rather 101, 102… 105 keys generic keyboard or some vendor-specific selection not matching your actual keyboard). If you’re running KDE, have a look at the “Systemeinstellungen” program, “Hardware”, “Eingabegeräte”.

Regards,
Jens

SLES 11 SP 2, x86_64
I would put this in my forum signature, but I can’t figure out where to set it.

There is no file ~/.i18n, the only dot file starting with .i in the home directory is .inputrc.

That would be interesting, but I’m unable to do this. I tried to ssh to the server, but it refuses ssh connections. I also can’t choose a text console log-in, the options are KDE4, GNOME, IceWM, FVWM, TWM … I tried selecting GNOME but was logged in with KDE4 anyway. But I’ve seen someone else log in with GNOME successfully, not sure what he did differently. I’m using VncViewer to log into the Linux servers.

I’m running KDE. What does NLS stand for? $LC_ALL is not set, which other $LC_* variables should I check?

There is non-YaST “Configure Desktop” in the K-Menu, which says “Personal Settings” in the title bar, and when going into any setting and back out it suddenly says “System Settings” in the title bar, do you mean this? It has “Keyboard & Mouse” (which in a later KDE release was replaced with Input Devices / Eingabegeräte), but Keyboard only has the settings delay, rate, numlock and key click volume.
Or do you mean in YaST > Hardware? There is “Hardware-Informationen” and “Tastaturbelegung”, but no input devices and no keyboard. Clicking on Tastaturbelegung shows a sandclock for a few seconds and then does nothing at all.

:confused:

Hi monika,

[QUOTE=monika;19106]SLES 11 SP 2, x86_64
I would put this in my forum signature, but I can’t figure out where to set it.[/QUOTE]

when logged in through the web interface, go to “Settings” (the link in the upper right of the screen, above the search field), then in the left navigation pane, you should see “My Settings” with a “My Profile” sub-entry and “Edit Signature” link as second.-to-last link…

Might it be the sshd is not running? Are you allowed to start it, or is this out of the question? Personally, I much prefer text-mode connections for administrative tasks, as less gets in the way of things. Not to mention bandwidth issues in case of off-site access :wink:

National Language Support. As to the various LC variables - I’d have to look them up, are any set at all?

Hm, as I’m not using GUIs on servers, I cannot tell if this is where it has to be set - in the end, the configuration has to influence the Xserver, which may be set differently in your version of KDE (I only use that on desktop systems, later opensuse versions in my case).

No, the above KDE way was what I was after. But as you use VNC to access the server, that’s probably working differently from what I was about to tell you - I had assumed you’re working from the local server console.

Adding VNC brings in another layer of complexity… your Xserver needs to be able to tell what type of keyboard your graphical client emulates. And maybe some information on preferred language is sent by the client as well, leading to the reported problems?

What type of client (and which client platform) do you use? That information will help others to assist you with this problem.

Unfortunately, for lack of experience I cannot give more information on this part of the problem - I’ve had my share of problems using VNC and alike when accessing specific products requiring it (Xen virtual machines with GUIs, mainly) and try to avoid that type of solution wherever possible :wink:

Could anyone more experienced with VNC take over, please?

Regards,
Jens

Strange, under My Settings, My Profile there are just four entries, none of which is Edit Signature: Edit Profile, Edit Profile Picture, Edit Avatar, Profile Privacy.

service sshd status as root says it’s already running.

I have now installed an ssh client on the Cygwin on my computer, from there I was able to ssh into the server (previously I had tried to make an ssh connection on the server to itself, maybe this is not possible in principle?). There the language for error messages was English and echo $LANG returns en_US.UTF-8. So it appears to be caused by some KDE stuff, I guess?

I’m not sure, I only found via Google that $LC_ALL should be checked, I don’t know which $LC_* variables exist.

[quote]No, the above KDE way was what I was after. But as you use VNC to access the server, that’s probably working differently from what I was about to tell you - I had assumed you’re working from the local server console.

Adding VNC brings in another layer of complexity… your Xserver needs to be able to tell what type of keyboard your graphical client emulates. And maybe some information on preferred language is sent by the client as well, leading to the reported problems?

What type of client (and which client platform) do you use? That information will help others to assist you with this problem.[/quote]
I can also log in from a local server console directly on the VMware server (it’s just very slow and unreliable). You are right, the keyboard problem turned out to be completely caused by the VncViewer, on the local console Alt Gr works fine.
I’m on Windows and using the Java VncViewer in Firefox.

On the local server console I was also able to log in with GNOME and in the shell there there was no language problem, all error messages appeared in English.

Now something funny happened. After I had logged in via ssh and in the local server console with first KDE, then GNOME, the behavior in the Java VncViewer in Firefox also changed. First when logging in, even though (as always) GNOME was selected on the logon screen, which previously resulted in KDE starting, FVWM started. I couldn’t even figure out how to log out, I just connected again in another browser tab and selected KDE. KDE started - and now the language problems are gone! Both the error messages in the konsole and the entries in YaST2 are in English now. Even though I didn’t change anything.

I think logging in on the local server console with GNOME once (or maybe the ssh connection) somehow set the secret switch to “more magic” :stuck_out_tongue:

Hi monika,

ok - must have to do with my sysop status then… do you want me to ask those who know?

[QUOTE=monika;19118]service sshd status as root says it’s already running.

I have now installed an ssh client on the Cygwin on my computer, from there I was able to ssh into the server (previously I had tried to make an ssh connection on the server to itself, maybe this is not possible in principle?). [/QUOTE]
This should definitely work - I do it a lot. I can only guess about the cause - you might look up the server’s IP address (via “ifconfig”) and ssh to that address instead of the server name. If that works, some name service is not working as expected (old /etc/hosts entry?) or maybe the server is multi-homed, but sshd is not listening on all interfaces (and you got to the “wrong” one).

Yes, seems so - and may be some interaction between the VNC client and the VNC-enabled Xserver rather than plain KDE settings. Tools acting too intelligent, perhaps.

user@host > env|grep LC_

will give you a list of all variables having “LC_” either in their name or value.

[QUOTE=monika;19118]I can also log in from a local server console directly on the VMware server (it’s just very slow and unreliable). You are right, the keyboard problem turned out to be completely caused by the VncViewer, on the local console Alt Gr works fine.
I’m on Windows and using the Java VncViewer in Firefox.

On the local server console I was also able to log in with GNOME and in the shell there there was no language problem, all error messages appeared in English.

Now something funny happened. After I had logged in via ssh and in the local server console with first KDE, then GNOME, the behavior in the Java VncViewer in Firefox also changed. First when logging in, even though (as always) GNOME was selected on the logon screen, which previously resulted in KDE starting, FVWM started. I couldn’t even figure out how to log out, I just connected again in another browser tab and selected KDE. KDE started - and now the language problems are gone! Both the error messages in the konsole and the entries in YaST2 are in English now. Even though I didn’t change anything.

I think logging in on the local server console with GNOME once (or maybe the ssh connection) somehow set the secret switch to “more magic” :p[/QUOTE]

Tell you what - I know why I steer away from such “solutions” and now feel encouraged to keep it that way :smiley:

Good to know the problem was “solved” for you (although the original cause will now probably be buried forever, hehe).

Regards,
Jens