Templates disappear

just noticed in 1.2.1 that if I make a new template (ex inc vxlan), after adding new environments, my templates just disappears.

Any comments?


Could you provide some more details? I havent had templates disappear?

Are you using the standard Rancher catalog or a default library?
Are they public or private templates?

What I do is that I make an environment template, removing ipsec and adding vxlan.

Then I make a new environment with my new vxlan environment template.

Then, my template dissapears from the list of environment templates.

I’ve tried several times on different installations and it happens every time.
This is an 1.2.2 standalone rancher


@hwaastad - I am unable to reproduce your problem. Just to reiterate steps:

  1. Go to manage templates
  2. Add template (use cattle orchestration)
  3. remove ipsec and add vxlan (Leave all other modules and I named my template cattle2)
  4. Add environment and use cattle2

Results - template is missing? My template is still there, are you leaving the manage environment page? Is the template name the same everytime? Have you tried a different name for your template? Did you fill in description? Is this a public or private template? Just trying to see if I can find anything different.

The issue is that it does’nt happen all the time.

it’s a public template.

Try adding env’s using this template, add stacks and switch between environments then It can happen.
I do not have any hosts added to the env’s.

But, if you cannot reproduce, I’ll see if its possible for me to make this testable.


I’ve never seen this either… Is there anything in the audit log? Or checking the database table to see is the missing ones are there might be worthwhile, though presumably they’re just marked removed…

will try to do a recording while clikcing around.

found another issue while checking audit logs.

  1. Add a new environment
  2. check audit logs
  3. delete and purge environment
  4. check audit log
  5. manage environments -> all purged env are shown.
  6. refresh page, they disappear.
  7. do 4-> 6 again

I’m seeing the same issue with disappearing templates:
• create a new environment template (all defaults + Route53 DNS)
• log on tomorrow and it’s gone

It’s happened twice now:
• once I created a new template and it was gone the next day
• another time, I edited the default cattle template and it was reverted to default the next day

@hwaastad - I was able to reproduce your issue where the removed environments kept showing back up. Thank you for tracking that down. I had seen it before but couldn’t quite figure out how. I entered it into Github, https://github.com/rancher/rancher/issues/7409 if you wish to track it’s progress.

I still haven’t been able to reproduce the deleted environment templates. But I will keep trying. Thanks!


This thread seems to have morphed from templates disappearing to deleted environments coming back.

I’m still seeing the original issue of templates disappearing. Sometimes it happens almost immediately. The disappeared templates are always public, but I’m not sure if that is relevant because we don’t have private templates. I’ve seen this on both 1.3 and 1.4.1.

I was finally able to reproduce this. Looks like ‘public’ templates are being removed when they fail the git clone process to make them public. An issue was entered and I commented on it. Here is the issue if you would like to track it:

1 Like