Unable to install libgc-devel package

Hello All

We got a new SLES 15 MP5 Server. We are trying to install gcc. Of course we cannot use zypper as the server is iolated and not connected to network. So we have taken rpm option. Download .rpm from SUSE website, copy to server and install

When we tried to install gcc it gave a error that libgc-devel package is required. So we tried to install libgc-devel package. But that failed with error linux-kernel-headers are required.

We ran this command - /usr/src/linux-$(uname -r | sed “s/-default//”)/include/

got the error that -bash: /usr/src/linux-5.14.21-150500.53-default/include/: No such file or directory.

So what package we need to install to get the linux-kernel-headers? Any help will be highly appreciated

@sujeeth_kamath Hi and welcome to the Forum :smile:

Put in the install media DVD/USB and use that assuming it’s a default install with no updates… it can be added as a local repo if not already there from the install.

1 Like

sure let me try. thanks for the update

I would like to get more educated on this platform because i don’t understand a single thing and would like to be an owner or runner on this knowledge